3

I recently upgraded from 12.04 tot 14.04, gnome flashback Compiz. Conky tranparant behaves abnormally now and I can't fix it.

Transparency turned off, conky acts normally. Transparency turned on, it is as if upon each refresh, the previous layer isn't removed, so they stack onto eachother.

See screenshots:

no transparency:

enter image description here

transparant:

enter image description here

normal:

enter image description here

I've tried all sorts of combinations of the relevant section in .conkyrc but to no avail...

Relevant lines in .conkyrc:

## Create own window in instead of using desktop?
#
own_window yes
own_window_transparent yes
#own_window_type normal
own_window_type override
own_window_class conky-semi
#own_window_hints undecorated,below,sticky,skip_taskbar,skip_pager
####
## Some distros also require the following 2 lines.
#
#own_window_argb_visual yes
#own_window_argb_value 0

I've recently noticed it's variable: it always does this right after startup or 'conky' in terminal, but after a while it stops (so conky's normal), but then after a variable time interval, the 'stacking' starts again...

NB the more I look at it, the more I think it could be a window compositing or window manager and NOT a conky issue. Strange, because apart from the conky refresh issue, the system is running flawlessly (so far...)

Thanks for any help

12
  • I'm afraid I can't help you, but I would love to know what is the name of this package/tool – Geo Sep 7 '14 at 15:39
  • Try with own_window_type conky and also uncomment the own_window_hints line. – g_p Sep 7 '14 at 17:20
  • Tried each separately and combined... no luck... Thanks anyway though – Tinellus Sep 7 '14 at 17:56
  • own_window yes own_window_type pannel own_window_transparent yes own_window_hints undecorate,sticky,skip_taskbar,skip_pager,below . Which is working fine on my Gnome desktop. – g_p Sep 10 '14 at 19:43
  • 1
    Where did you get that theme?! I love it and would like to use it. – Ken George Mar 2 '15 at 15:10
1

I've run into same problem. Transparency does not work with window_type override. And window_type desktop disappears on show_desktop. I've come up with this config for ubuntu 14.04 with unity and compiz

own_window_type panel own_window_hints undecorated,below,sticky,skip_taskbar,skip_pager

0
0

For me this works, even though I don't use compiz and 14.04. After applying new values to .conkyrc did you restart conky in terminal like this killall conky, then conky?

background yes
update_interval 1

use_xft yes override_utf8_locale yes
xftalpha 0.84
uppercase no

own_window yes
own_window_argb_visual yes
own_window_transparent yes
own_window_class conky-semi
own_window_hints undecorated,below,sticky,skip_taskbar,skip_pager

2
  • I already have the same background and update_interval parameters. Inserting the 'use_xft...' phrase, changes a lot of things, but not the refresh issue. I always do killall conky followed by conky – Tinellus Sep 14 '14 at 18:17
  • To bad. Have you looked through the options in man conky?! – v2r Sep 15 '14 at 16:40
0

I fixed it with this setup

-- — WINDOW — #
    own_window_argb_visual = true,
    own_window_argb_value=0,
    own_window=true,
    own_window_transparent=true,
    own_window_hints='undecorated,below,sticky,skip_taskbar,skip_pager',

-- — BORDER — #
    border_inner_margin = 1,
    border_outer_margin = 1,
    border_width = 1,

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.