1

When i start the pc it boots fine but then it just shows gray background and nothing else if i move the mouse it shows the cursor on the gray screen also i am able to login into it by typing "Enter password Enter" although i am not able to see login happening on screen it does login and redirects to desktop and after that if i take screenshot it looks like this Screenshot as you can see in the screen shot its two displays but actually there is only one display attached. if i move the cursor to the right edge it goes outside the monitor,seems like it is going inside "buit in display" if i disable the default display it seems working fine but every time i restart i have to disable it and the login problem is insane any one other then me can't figure out how to login to my pc.

I have the same problem on Ubuntu and Ubuntu Gnome 14.04 LTS I have LG 22M35 screen which is big 22 inch screen.

  • Have you tried changing greeters? – Sergiy Kolodyazhnyy Sep 29 '14 at 9:36
  • let me google what is greeters? – Dhruv Mevada Sep 29 '14 at 10:00
  • No i haven't tried changing greeters – Dhruv Mevada Sep 29 '14 at 10:01
  • i strongly believe the problem is related to Display Configuration because it works fine after i disable to built in display – Dhruv Mevada Sep 29 '14 at 10:04
  • Have you upgraded your system to the latest stable version? Also go to Software & Updates-> Additional Drivers check if there are any display drivers to be installed on your system. If so, choose appropriately such as X.Org and restart. – user271219 Sep 29 '14 at 11:05
1

This problem (AFAIK) is not Ubuntu's fault. It is the graphics card itself.

What I believe is happening is that the graphics card is creating a "ghost" monitor. It's (usually) disabled unless it's needed by the computer. This allows the system to use the monitor without having to reboot.

A potential patch for this is to simply disable the extra monitor, unless needed. If you have a laptop, look for the "Mirror Mode" display. Hit it until the second monitor disappears. You might also have luck just disabling from the Displays menu.

| improve this answer | |
  • i am currently doing that, disabling the ghost display by hand but is there any way to make it happen automatically? as user can't even see the login(lightdm or gdm) if the ghost display is enabled – Dhruv Mevada Oct 3 '14 at 6:25
  • @TechnodHr Bios. I guess. – Kaz Wolfe Oct 3 '14 at 8:04
1

This sounds like a known, on-going bug with Xserver for Ubuntu 13.10 and 14.04. Here's a couple links with workarounds and a bug thread for NVidia cards:

Unknown display besides laptop Built-in display

Ubuntu detects a non-existing screen

Not sure if you tried to upgrade your Xserver or what HWE you're using but you may want to try that. More info on your system's configuration might help get the proper diagnosis for this problem.

| improve this answer | |
  • Problem: It's not only Linux. I've seen this happening in Windows, OSX, whatever. – Kaz Wolfe Oct 5 '14 at 9:36
  • I haven't seen this on other OSs but it could be possible. – Chef Pharaoh Oct 8 '14 at 20:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.