-1

i installed ubuntu 14.04 on my old htpc and for some reason i cannot output 1080p video. i already tried going to the display settings, though my highest available resolution was 1024 on 768. In addition i tried running windows and it worked flawlessly.

specs:

  • motherboard: GigaByte FSB1066 GA-945GCMX52
  • proccesor: Intel® Pentium(R) Dual CPU E2140 @ 1.60GHz × 2 (32b)
  • onboard graphics card:Intel® 945G x86/MMX/SSE2
  • ram: Soka DDR2 2GB
  • HDD: Seagate 80GB 7200RPM
  • power supply: Zeus ATX-520W
1
  • Welcome to AskUbuntu! Please provide some more information, such as your graphics card and the used driver.
    – s3lph
    Sep 5 '14 at 15:01
1

Your issue is that you probably have a Nvidia card or AMD card, and you don't have proper drivers for it. If you could post your system specs in your answer, it would help a lot. Also post if you have integrated or on board graphics, and let me know if you have them disabled or not(If you know).

I've found that manual installs work best for installing nvidia drivers, so go to here and download the latest drivers. By default, it'll most likely go into /Downloads, but if not, just know where it is. Then, you'll want to press

ctrl + alt +F1-F6 (each is a different login)

And then sign in to your account. Then, you'll want to use

sudo stop lightdm (or sudo service lightdm stop)

This shuts down the things that are using the GUI, so they can be updated.

Then run

chmod +x ~/* Folder that said driver is located in * / * Driver *

For example,

chmod +x ~/Downloads/NVIDIA-Linux-x86_64-343.13.run

Make SURE that you have the entire name of the driver, otherwise this will not work! Caps do matter!

What you just did was make the file executable. Next, you'll want to run the following command, changed of course like the example above to fit your directories/driver versions.

sudo sh ~/Downloads/NVIDIA-Linux-x86_64-343.13.run

For me, tabbing the rest of the NVIDIA-Linux-x86_64-343.13.run file does not work for me, but it is CRUCIAL THAT YOU DO THIS. If nothing happens after you run the second command, check your caps and spelling to make sure they are right. You have to go through the program using the keyboard to correctly install it. For me it will tell me that something went wrong right on the bat, just keep going and see if it still works. If it asks you to install 32 bit libraries, do so. Some programs (like steam games) will not run unless you have these installed.

After all of the above has been done, one final command must be completed, or of course you could reboot.

sudo start lightdm (or sudo service lightdm start)

Then, you'll do

ctrl + alt+ F7-F9ish (F7 is usually default, some people have different F keys though)

If you have an AMD card, or integrated or onboard graphics let me know as they are a lot different to install. I've never personally installed AMD drivers before, so I would recommend googling around on how to install them before asking for more help on installing those drivers.

5
  • thanks for the help. i'm using onboard graphics with an old pentium proccesor. i'm adding the full system spec's right now
    – Pit Omer
    Sep 5 '14 at 22:09
  • Ah I see. Weird that it does not work by default. I will look into how to install Intel onboard graphics now. Sep 6 '14 at 1:58
  • Alright, you can try the following, >sudo apt-get install xserver-xorg-video-intel If that doesn't do anything, try >sudo apt-get update Then run that command again. See if that does anything useful. Sep 6 '14 at 2:04
  • i tied both of them, it wrote something on the screen and when it finished i still couldnt use 1080p
    – Pit Omer
    Sep 6 '14 at 15:44
  • Hmm, that's weird. Not sure what to do. Do you have any more information or updates that you have found? Sep 15 '14 at 16:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.