147

Is there a hotkey to switch between tabs in Ubuntu's native terminal app? I'm using the netbook version of ubuntu.

3
177

You can also use Ctrl+PgUp/PgDn to go to previous/next tab.

5
  • I had to use CTRL+SHIFT+ PgUp / PgDn
    – jonnybot
    Oct 16 '15 at 19:48
  • not cool. Mac doesn't have it.
    – Vlad
    Dec 16 '15 at 22:47
  • 3
    @Vlad on my macbook it appears to be CMD+SHIFT+LEFT_ARROW/RIGHT_ARROW, maybe that works for you as well.
    – isaias-b
    Jan 3 '16 at 0:29
  • Doesn't seem to work with numpad PgUp / PgDn keys I typically use on my laptop, but the dedicated PgUp / PgDn keys do work. I was able to edit the shortcuts to use the numpad easily, as described below :)
    – jocull
    May 24 '16 at 14:41
  • For me ctrl + function + up/down works Dec 15 '17 at 11:28
66

You mean gnome-terminal?

To switch between tabs you can use Alt-n, where n is the tab ordinal number.

  • Alt+Maj+n if using an azerty keyboard, caps-locked or not...

By the way, this works the same in Gedit.

1
  • 1
    And it also works in Chromium, I just found out!
    – DSimon
    Dec 21 '16 at 1:21
13

I'm guessing you mean the default distributed (pre-installed) gnome-terminal.

You can set your own shortcuts easily, just go to menu Edit>Keyboard Shortcuts...

gnome-terminal keyboard shortcuts settings as seen on ubuntu 12.04

Bonus tip: If you wanna take a look to the real "native terminal" or tty (teletype interfase) just hit Ctrl+Alt+F1 (It works with almost any Function key), and don't panic, you can come back to the "graphical interfase" by hitting Ctrl+Alt+F7

1
  • Is it any way to set them to Ctrl+Shift+Tab and Ctrl+Tab?
    – Pavel
    Dec 18 '18 at 1:00
8

Simple and standard for all:

for switching/moving tabs:

Ctrl + pg up

or

Ctrl + pg dn

for positioning tabs (not switching):

if you want to position tabs, but not switch/move. is useful when too many tabs are open in web browser and or terminal and you want to group/lineup tabs. you can do this.

CtrlShift + pg up

or

CtrlShift + pg dn

Pro Tip:

try this in your browser tabs. and see what happens.

3
  • 1
    This has started inserting ;5~ for me lately instead of switching tabs. Any idea what would cause that?
    – hughes
    Oct 4 '16 at 7:30
  • it does happens when a process you or some other application started did not left the terminal and while you press other keys it prints some odd characters. Oct 4 '16 at 7:40
  • This works in some Editor too, e.g Geany. The switch also works in IDEA, though positioning doesn't.
    – user218867
    Mar 5 at 22:48
5

For anyone using Konsole, that comes with Kubuntu (or KDE), the shortcut is -

Shift+, Shift+

1
  • I don't know who downvoted this answer! It deserve more upvotes
    – Anwar
    Jan 1 '17 at 6:12
0

Alt + Shift + n, where n is the tab number starting from 1, works for me on Ubuntu 18.04 with Gnome Desktop Environment.

0

For the MacBook Pro (I suppose it's the same with other macs) running Ubuntu on VMWare there are two options:

  1. With the large Apple Magic Keyboard with Numeric Keypad, use the arrows below F15 (don't know their official names, but I now believe they're the Page Up/Down keys already mentioned) with CTRL, but not the regular cursor/arrow keys at the bottom of the keyboard:

control+ or control+

  1. With the built-in laptop keyboard or with the external keyboard use the function key, plus control, plus the regular up/down keys:

fn+control+ or fn+control+

In other words, option 2 should work in all cases, but if you have the large keyboard there's an additional convenient shortcut.

By the way, both options also allow switching between Google Chrome and Opera tabs. Haven't tested with Firefox yet.

Not the answer you're looking for? Browse other questions tagged or ask your own question.