0

Time for yet another graphics card Q. Sorry in advance, but I have tried what I take to be the 'normal' way already (see below), so here it goes:

I have an Intel Atom D525 1.8GHz with a discrete NVIDIA ION 512MB DDR3 graphics card, on which I run (for reasons I will spare you) Ubuntu 11.10. What I want to know is primarily how to fix the laggy behaviour on my current setup. The machine is supposed to be able to support HD video. In fact, the spec sheet says:

  • Digital HDMI v1.3 output (DVI via adapter), max. 1920 x 1200
  • Analog VGA output, max. 2048 x 1536
  • NVIDIA PureVideo HD supports full HD decode (1080i/p)

I have the machine connected to the TV via HDMI. Watching small video files (sub 1GB) all is fine, but most often 720p and ALL 1080p video files I have are very sluggish. And watching flash videos via the browser is likewise awful.

I have updated to the latest NVIDIA drivers through

sudo add-apt-repository ppa:ubuntu-x-swat/x-updates
sudo apt-get update
sudo apt-get install nvidia-current

but with no success: it is just as sluggish as always.

Note (if at all relevant): if instead of playing video directly from my machine, I go via a media server (I use serviio), I can watch the HD content via my TV or PS3.

Finally, here is some additional lspci output:

VGA compatible controller: NVIDIA Corporation GT218 [ION] (rev a2) (prog-if 00 [VGA controller])
Subsystem: Holco Enterprise Co, Ltd/Shuttle Computer Device 4003
Flags: bus master, fast devsel, latency 0, IRQ 16
Memory at fd000000 (32-bit, non-prefetchable) [size=16M]
Memory at d0000000 (64-bit, prefetchable) [size=256M]
Memory at ce000000 (64-bit, prefetchable) [size=32M]
I/O ports at cc00 [size=128]
[virtual] Expansion ROM at fe980000 [disabled] [size=512K]
Capabilities: [60] Power Management version 3
Capabilities: [68] MSI: Enable- Count=1/1 Maskable- 64bit+
Capabilities: [78] Express Endpoint, MSI 00
Capabilities: [b4] Vendor Specific Information: Len=14 <?>
Capabilities: [100] Virtual Channel
Capabilities: [128] Power Budgeting <?>
Capabilities: [600] Vendor Specific Information: ID=0001 Rev=1 Len=024 <?>
Kernel driver in use: nvidia
Kernel modules: nvidia, nouveau, nvidiafb
0

My system was so badly beaten up that I decided to upgrade to a still supported version, 12.04, and so after cloning the disk with clonezilla and pressing upgrade (and a lot of waiting), I was happy to see that nothing I cared about was broken, and the video problem was fixed after installing the recommended nvidia drivers. In other words, taking the plunge and upgrading fixed it!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.