0

My Internet connection is not working since I restarted my laptop (which is very old). Here's what I've tried:

  1. Ran sudo -s then tried /etc/init.d/networking stop:

    * Deconfiguring network interfaces...
    Root@carlos-laptop: ~#
    
  2. Ran status networking:

    Networking stop/waiting
    
  3. Ran status network-manager:

    network-manager start/running, process 621 
    
  4. Running restart networking gives me: restart: unknown instance:

  5. I successfully restarted network-manager.

  6. Ran /etc/init.d/networking start.

    It says I should instead use the service(8) utility and "since the script you are attempting to invoke has been converted to an upstart job, you may also use the service(8)... ...networking stop/waiting".

  7. Tried ifup eth0 and got ignoring unknown interface eth0=eth0

    ifdown eth0 gave: interface eth0 not configured

  8. Then I configured /etc/network/interfaces in nano.

    Specifically, I deleted loopback lo and inserted eth0.

    Then I ran /etc/init.d/networking restart. (By this point i thought it would work, but i was wrong.) I got:

    *reconfiguring network interfaces...
    Internet Systems Consortium DHCP Client V3.1.3
    Copyright...bla all rights reserved
    Listening on LPF/eth0/00:90:f5:4d:f8:ed
    Sending on --as above--
    Sending on Socket/fallback
    DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 4;6;7;14;19;11
    No DHCPOFFERS recevied.
    No working leases in persistent database - sleeping. 
    
  9. I tried to ping www.google.com and got ping: unknown host www.google.com.

  10. Ran dpkg --configure -a which gave:

    Setting up libsdl-ttf2.0-0 (--configure): subprocess installed post-installation script returned error exit status 2
    Errors were encountered while processing: 
        libsdl-ttf2.0-0
    
  11. Tried restart networking again:

    There is already a pid file /var/run/dgclient.eth0.pid with pid 1811 killed old client process, removed PID file
    

    Internet Systems ...
    Got the same answer- no DHCPOFFERS received.

  12. Started Firefox, went to Google:

    -XML Parsing Error: not well-formed
    Location: jar:file///usr/lib/firefox/omni.ja!/chrome/toolkit/content/global/etError.xhtml
    Line number 23, Column 51:
    <link rel="stylesheet" href="chrome://global/s
    
  13. Tried to restart the laptop, and got nothing again.

  14. Ran route -n:

    Destination 169.254.0.0
    Gateway 0.0.0.0
    Genmask 255.255.0.0
    Flags metric ref U     0      0
    Use Iface 0 eth0
    
  15. Did sudo dhclient eth0, got: no DHCPOFFERS received

  16. Restarted again, opened /etc/network/interfaces. It was empty. NetworkingManager.conf is also empty.

I don't know what to do. I am so frustrated right now and have been writing this for an hour on my friend's iPhone. So if you can, help me, thank you.

  • Welcome to Ask Ubuntu! We need more hardware information to help you. Please look at this question and then edit your question adding the information. – Eliah Kagan Sep 4 '14 at 23:09
1

Paste this into /etc/network/interfaces and reboot the computer:

auto lo
iface lo inet loopback

auto eth0
iface eth0 inet dhcp
  • No need to restart though, you can run sudo ifdown eth0 && sudo ifup eth0 after making the edits. That's for ubuntu 14.04, in prior versions you can run sudo service networking restart. – Esteban Sep 3 '15 at 17:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.