I'm trying to set up my personal computer to access my work file shares. I mounted successfully and I can read files just fine, but I have no write access. Here is the line I added to my fstab:

//srvfi/Tests /media/Tests cifs username=dbrown,password=******,iocharset=utf8,sec=ntlm 0 0

What do I add?

Usually, this share is automatically added to my account on the Windows 7 of the work computer. I just log into the server with the same information as my Windows log-in.

  • Okay, I can mark this as solved now. After many failed chown's, I realized I should just append the line with file_mode and dir_mode arguments. Working just fine now. Thank you!
    – user323419
    Sep 4, 2014 at 19:21

1 Answer 1


Adding an answer here so that I can mark it as solved. Everything worked after I added file_mode=0777,dir_mode=0777 to the mount line. chown just gave me permission denied errors.


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy