0

I downloaded Aptana Studio 3 Standalone version and extracted the folder in it. I tried to give executable permissions to AptanaStudio3. But I could not. I guess it happened because of the partition being NTFS formatted. So I moved the 'Aptana_Studio_3' folder to my home partition which is ext4 formatted. Tried giving AptanaStudio3 exec permissions again.. And it worked! So far, so good!

Now let me see if I can give it a "Launcher shortcut" and "searchable in Launcher dash" option.

Googling....

Sysads Gnome Panel Moved the Aptana_Studio_3 to /opt and everything in there but it confused me, especially this line "Also click icon to choose the Aptana icon in same location".

Anyway I removed gnome-panel after that.

Googling again....

Sam Clarke Aptana Install in Ubuntu 12.04 This link has been referred by many for installing Aptana in Ubuntu. I guess this works, for even Ubuntu 14.04. The folder is still in /opt . But even after I followed all the instructions in there, I could not get the Launcher icon to work. I could run it, if I went to sudo /opt/Aptana_Studio_3/ and opened AptanaStudio3. And then I could even lock its orange-gears icon to the launcher bar. But once I closed Aptana and clicked on the launcher icon again, it just blinks but nothing happens. Aptana doesn't open.

Googling again...(You must be frustrated by now, but please read on)

AskUbuntu solution /usr/bin Here the 1st answer suggests to move the 'Aptana_Studio_3' to /usr/bin if I want to use terminal to open Aptana. Cool! I like opening stuff through Terminal. And since I have already tried everything else this can't hurt, right? I even created a .desktop file on my own. Here it is:

[Desktop Entry] Version=1.0 Name=AptanaStudio3 Comment=Aptana Studio 3 Exec=/usr/bin/Aptana_Studio_3/AptanaStudio3 Icon=/usr/bin/Aptana_Studio_3/icon.xpm Terminal=false Type=Application Categories=Application;

(I couldn't do the markdown formatting properly here.)

But the same thing happens..... No icon ever appears on the Launcher bar. I can lock the icon after opening Aptana from /usr/bin/Aptana_Studio_3/ and the icon doesn't open Aptana again.

Help me. Where am I going wrong? Maybe its because of the gnome-panel? My .desktop file is wrong perhaps?

0

I also had the same problem and I fixed it using almost same method. In order to things works as you wish, check following things. 1.I assume .desktop file was created in you desktop. After you created it, that file does not have execution permission by default. So right click your .desktop file -> properties -> permissions. Then tick Allow executing file as program. then close that property window. This should give you the icon properly. If you do not get it write check all the file names and paths are correct for icon and program.

2. After that in order to appear it in launcher you should copy this into applications folder.

sudo cp /home/YOUR USERNAME HERE/Desktop/AptanaStudio3.desktop /usr/share/applications/

then enter your password. This will copy your .desktop file to applications folder. This will allow you to search through launcher.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.