1

After a recent upgrade of 14.04, an icon "Show Desktop" appeared in my launcher bar.

I removed it with Unity Tweak Tool.

A new keyboard shortcut was also setup: Super+D now also shows the desktop. This is annoying, since pressing Super+Alt+D in that order is not the same as pressing Alt+Super+D in that order. The former is erroneously interpreted as Super+D on my machine.

What I would like to do in a first step is to disable Super+D, but I cannot find where I can turn this off.

Here are the things I checked:

  • nothing in Settings > Keyboard
  • there is something in CompizConfig Settings Manager > Unity > General, but it is set to <Control><Super>d. Disabling it does not disable <Super>d.
  • I disabled the shortcut in Unity Tweak Tool > Window Manager > Keyboard shortcuts > Show desktop
  • gconf-editor -> apps/compiz-1/plugins/showdesktop, I can't find anything about keyboard shortcut there
  • dconf-editor -> org/compiz/profiles/unity/plugins/unityshell -> show-desktop-key is Disabled

How do I disable the new <Super>d shortcut?

  • By default here super+d does nothing. However if the show desktop icon is added to the launcher then it's enabled. To disable super+d try - in System Settings > Appearance > Behavior disable the Add show... box or if already then enable then disable. Then log out/in & check. – doug Sep 4 '14 at 13:17
  • In terminal run dconf -reset /org/compiz/profiles/unity/plugins/unityshell/show-desktop – αғsнιη Sep 4 '14 at 13:18
1

As hinted by @doug in the comments, I needed to log out and in for the change to apply.

Removing the "Show Desktop" icon worked immediately, which is why I expected the shortcut to also be removed immediately. It was not.

It is still very strange that the shortcut was active, but not visible in any of the settings tools I mentioned in the question. It looks like the shortcut was hard-coded together with the icon enable/disable. Why the icon turned up at my last system update is also a mystery.

  • Keyboard shortcuts can be overriden via "Keyboard and shortcuts" item in control panel – Anwar Nov 30 '16 at 14:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.