5

I installed seahorse and seahorse-nautilus, so I can encrypt any file with right-click in Nautilus, that works, wonderful.

But there is no "Decrypt" menu on any file (not even .pgp files). Is it a bug?

No decrypt

This 2009 thread says the problems can be solved by installing seahorse-plugins, but:

$ sudo apt-get install seahorse-plugins
Reading package lists... Done
Building dependency tree
Reading state information... Done
Package seahorse-plugins is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source
However the following packages replace it:
  seahorse-nautilus:i386 seahorse-nautilus
E: Package 'seahorse-plugins' has no installation candidate
10

The seahorse-plugins is deprecated since 10.04 and as stated in the error message, the seahorse-nautilus package now replaces it.

For details you can look at the source package and its debian/control file:

Package: seahorse-nautilus
Architecture: any
Depends: ${shlibs:Depends},
         ${misc:Depends},
         seahorse-daemon (>= 3.2.2)
Recommends: seahorse
Replaces: seahorse-plugins
Description: seahorse plugins and utilities for encryption in GNOME
 Seahorse nautilus is an extension for nautilus which allows encryption
 and decryption of OpenPGP files using GnuPG - the GNU Privacy Guard 
 program.

Regarding the missing menu item, it happens if you tried to open the encrypted file with Gedit as a new File association is then created for this new (MIME) type.

To revert such association, edit the $HOME/.local/share/applications/mimeapps.list file to remove (or comment) the following line:

enter image description here

Then restart Nautilus.

Finally to Decrypt a .pgp with Nautilus, right-click on it and select the Open With Decrypt File menu item:

enter image description here

| improve this answer | |
  • That's the problem. There is no Open With Decrypt File item in the the Nautilus context menu, even for .pgp files. – Nicolas Raoul Sep 4 '14 at 9:47
  • @NicolasRaoul I've updated my answer as I've been able to reproduce your bug – Sylvain Pineau Sep 4 '14 at 10:02
  • 2
    restart nautilus via terminal using: nautilus -q && nautilus – eX00r Dec 2 '15 at 10:20
  • After installing seahorse-nautilus, double clicking on the encrypted file also works. – user68186 Mar 16 '17 at 18:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.