I am new to Ubuntu and probably have a noob problem, but it seems to me to be rather complicated, any help will be appreciated.

I've tried to add opacity property to windows via compiz configurator and suddenly unity has crashed. It won't run after reboot either.

I've tried:

  • compiz --replace

    It stops on "compiz (core) - Info: Starting plugin: session"

  • compiz --replace cpp

    It won't load plugin cpp, as it can't find it.

  • unity --replace

    It doesn't help:

    "Unknown job: unity-panel service ... No protocol specified ..."

    Tried to reinstall unity, and to reinstall ubuntu-desktop again no help, still empty screen after login.

  • dconf reset -f /org/compiz/setsid unity

    unity --reset-icons

    Still no help...

What's interesting here is that on the login stage I do see the top panel (with language, wi-fi etc...), but at the moment I log in, all of that disappears and there is empty screen.

Ubuntu is fresh installed, but I still do not want to reinstall it, as I have already done a lot to customize it.

1 Answer 1


Unity doesn't load, no Launcher, no Dash appears

This thread partly answers the question, but still not full. It really does help when you enaable ccsm, but you'll yet see empty screen even after reboot after the descrubed manipulations. However if you reexecute

dconf reset -f /org/compiz/
setsid unity
unity --reset-icons

everything works fine.. also I'm not very sure if reinstallation of unity, ubuntu-desktop and compiz had made some help here.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.