0

My wifi card detects my router, but can't connect to it. On windows 8.1, it connects with no trouble. I have made sure that I selected the right security mode, and I have entered the router's mac address and ssid manually. I have TL-WDN4800 wireless adapter and a cisco x3500 router. I have tried changing my router's security mode to wpa and also tried disabling security, and my computer still won't connect.

1

I have finally found the solution to my problem. There are only Linux supported drivers for the TL-WDN4800 V1... I figured out I actually have the TL-WDN4800 V3 and the v1 drivers are not supported with the V3 for whatever reason. The windows drivers for this card can be found from the official TP-Link website and can be installed on to linux with Ndiswrapper.

0
  1. Reset your router to its default factory settings. This will ensure nothing esoteric is set in the configuration. See your manual, but best is the 30/30/30 reset. While powered on, hold the reset button down for 30 seconds - don't release it. Pull the plug while holding the reset button and leave power off for 30 seconds - don't release the reset button. Reconnect power while holding the reset button for 30 seconds. Release the reset button. Power off, then on.

  2. The default config on the router should be IP 192.168.1.1 and it should be handing out addresses via DHCP. Your computer should pick it up as a viable network and connect. As should your smart phone. Nice to use the phone to confirm that the network is actually up.

If your phone doesn't connect and your computer doesn't connect, there is likely something amiss with the router itself. Or, you don't have any networking services running on it. Since you say your computer sees the router, neither of these seem likely.

When your equipment connects, it should do so with addresses like 192.168.1.xxx.

  1. Open a terminal window and type ifconfig. The results should show that your network card has an IP address. Also try ping 192.168.1.1 and you should get responses from the router.
  • Hi, I have tried both of your suggestions, and still, it won't connect. My phone connects fine, and the router's ip address is as you said it should be. I have installed the latest drivers for my WiFi card, and tried connecting to my friends's router: it works fine. Any other suggestions? – Adam Van Oijen Sep 5 '14 at 12:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.