'BIG' UPDATE I reinstalled the package (as I and binW pointed out) and now it recognises the modem as a modem. I configured the network, but I can't connect (acording to the 'lights' the modem shows I need to introduce the modem), so if you could help me with this last step i'll mention you in a comment on the source code of my next programm ;)

When I connect my usb modem to the computer it appears as a 'normal' usb, that is, it doesn't recognise it is a usb modem, so I can't connect my computer to the internet.

Is there any way to solve this? I already have installed usb-modeswitch, if that helps you :)

EDIT: the syslog ->

[  899.168328] usb 2-4: USB disconnect, address 4
[  899.219995] scsi 10:0:0:0: rejecting I/O to dead device
[  907.436065] usb 2-4: new high speed USB device using ehci_hcd and address 5
[  907.570709] usb 2-4: configuration #1 chosen from 1 choice
[  907.572502] scsi12 : SCSI emulation for USB Mass Storage devices
[  907.572849] usb-storage: device found at 5
[  907.572852] usb-storage: waiting for device to settle before scanning
[  907.572896] scsi13 : SCSI emulation for USB Mass Storage devices
[  907.573116] usb-storage: device found at 5
[  907.573118] usb-storage: waiting for device to settle before scanning
[  912.572899] usb-storage: device scan complete
[  912.573352] usb-storage: device scan complete
[  912.573607] scsi 12:0:0:0: CD-ROM            HUAWEI   Mass Storage     2.31 PQ: 0 ANSI: 2
[  912.573974] scsi 13:0:0:0: Direct-Access     HUAWEI   SD Storage       2.31 PQ: 0 ANSI: 2
[  912.580691] sr1: scsi-1 drive
[  912.580880] sr 12:0:0:0: Attached scsi CD-ROM sr1
[  912.580989] sr 12:0:0:0: Attached scsi generic sg3 type 5
[  912.581309] sd 13:0:0:0: Attached scsi generic sg4 type 0
[  912.594637] sd 13:0:0:0: [sdc] Attached SCSI removable disk
[  925.115931] ISO 9660 Extensions: Microsoft Joliet Level 1
[  925.116685] ISOFS: changing to secondary root

EDIT 2 Just in case it is relevant, it used to work out of the box on ubuntu 11.04, but not on 10.04 (my case) (I can't upgrade, don't ask me to do that, please)

EDIT 3 i've been doing some research and it seems it should work perfectly with usb-modeswitch, so I'll try to reinstall it.

  • 1
    Modem detection could take time - minutes - under some circumstances. Btw, does syslog contain anything interesting about the issue?
    – Paolo
    Jul 6 '11 at 12:25
  • I left it about 10 min, but still it recongises it as a usb storage device. I edited the OP with the syslog relevant
    – gumbo
    Jul 6 '11 at 12:53
  • Sometimes I had to switch between USB ports and then wait for the modem to be recognized. Often this happened after 3/4 minutes, other times it didn't happen at all. Seriously annoying, but at least I got a patch to short the detection times. Full story and details....hth in some way. Though looking at syslog I think we have different issues.
    – Paolo
    Jul 6 '11 at 13:21
  • Yes, it seems to be a different problem.
    – gumbo
    Jul 6 '11 at 13:55

Take a look at this answer: How do I set up an MTS MBlaze modem? Placed here for your convenience.

Have you tried ejecting the modem? Do not unmount. Simply eject the USB mode which will result in the modem be recognized as a modem. Then it will be available as an internet connection in your favorite Network Manager.

The setup then will be achieved by simply clicking on the connection and following easy setup process.

This worked for me in the Huawei Modems listed here: How do i configure huawei usb modem

Give ejecting a try and please inform.

Good luck!

I hope this can give you a clue.

Good luck!

  • Thanks, but that didn't solve the problem :(
    – gumbo
    Jul 7 '11 at 13:54

Try usb_modeswitch. You can install it with apt-get:

sudo apt-get install usb-modeswitch

So plug out your modem. Install usb_modeswitch and then plug in your modem. Hopefully it will work. But if it doesn't try rebooting your machine. More than a year ago I used it for my ZTE 3G modem and it worked perfectly. I did a write up about how I used my 3G modem in Ubuntu and it can be found here

More information on using usb_modeswtich can be found here

  • Ok, so I downloaded (as I can't acess internet directly on my ubuntu computer) both this packages link and reinstalled them, and... it worked!! (I don't know why it didn't work before, but...)
    – gumbo
    Jul 7 '11 at 14:44

It is very simple. Just go to terminal and paste this:

gksu gedit /etc/udev/rules.d/15-huawei-e175oc.rules

then open gedit window and paste this:

RUN+="/lib/udev/modem-modeswitch --vendor 0x12d1 --product 0x1446 --type  option-zerocd"

then save and connect your modem to the PC and it should work.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.