I am trying to use bluetooth audio speakers, as my integred laptop speakers are so awful... The speaker is a Bose Soundlink mini and works just fine with my smartphone for example.

When I try to use it with my laptop (Ubuntu 14.04), it works ok, until I begin to work. Then sound begins to shutter, with this kind of logs:

Sep  3 17:29:38 franck-ThinkPad-T430s pulseaudio[3673]: [bluetooth] module-bluetooth-device.c: Skipping 30147 us (= 5316 bytes) in audio stream
Sep  3 17:29:38 franck-ThinkPad-T430s pulseaudio[3673]: [bluetooth] module-bluetooth-device.c: Skipping 79152 us (= 13960 bytes) in audio stream
Sep  3 17:29:41 franck-ThinkPad-T430s pulseaudio[3673]: [bluetooth] module-bluetooth-device.c: Skipping 3467134 us (= 611600 bytes) in audio stream

This happens as soon as I type on the keyboard (be it in libreoffice or in a terminal, or whatever). The keyboard is not a bluetooth keyboard, in case you ask.

When using internal speakers, I don't suffer the same problem.

So, is there a trick to give the full bluetooth audio stack higher priority and get a consistent audio plackback ? (bluetoothd ? pulseaudio ? low level interupts ? ???)

UPDATE: my bluetooth controller is attached to (internal) USB.

$ lsusb -v -s 001:004

Bus 001 Device 004: ID 0a5c:21e6 Broadcom Corp. BCM20702 Bluetooth 4.0 [ThinkPad]
up vote 7 down vote accepted

I finally found a solution (in fact several one):

  1. Add threadirqs to my kernel params
  2. was better, but this was not enough, I also had to install rtirq-init

I then had an (almost) perfect bt sound playback.

Another option seems to use linux-lowlatency kernel. I still have to test this, but it should work. What is unclear is the drackbacks (power consumption ?).

  • I had the same problem. This solution works! Thank you. – Robert Jakubowski Nov 12 '14 at 11:12
  • Glad it helped you. Notice that I've also been using the lowlatency kernel since, with no apparent drawback I could notice... – alci Nov 12 '14 at 11:44

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.