2

I ran a standard apt-get upgrade yesterday. Since then, the nvidia drivers (nvidia-331-updates) don't seem to work anymore.

I did some digging and tried re-installing the drivers in different versions as well as booting different kernels. I can see that it fails to load the nvidia module

/var/log/Xorg.0.log

[  2127.801] (II) LoadModule: "nvidia"
[  2127.801] (WW) Warning, couldn't open module nvidia
[  2127.801] (II) UnloadModule: "nvidia"
[  2127.801] (II) Unloading nvidia
[  2127.801] (EE) Failed to load module "nvidia" (module does not exist, 0)

I then tried updating the alternatives:

~>> sudo update-alternatives --config x86_64-linux-gnu_gl_conf
[sudo] password for ingo: 
There are 3 choices for the alternative x86_64-linux-gnu_gl_conf (providing /etc/ld.so.conf.d/x86_64-linux-gnu_GL.conf).

  Selection    Path                                          Priority   Status
------------------------------------------------------------
  0            /usr/lib/nvidia-331-updates/ld.so.conf         8604      auto mode
  1            /usr/lib/nvidia-331-updates-prime/ld.so.conf   8603      manual mode
  2            /usr/lib/nvidia-331-updates/ld.so.conf         8604      manual mode
* 3            /usr/lib/x86_64-linux-gnu/mesa/ld.so.conf      500       manual mode

If I set this to 0, I have my nvidia binaries back in the path and can, e.g., run nvidia-xconfig (which I can't otherwise). I can also successfully probe the module via sudo modprobe nvidia, which otherwise errors out.

But here's the problem: If I log out and back in (or reboot) so that loading the module can take effect, the alternatives just jump back to option 3.

Does anyone know what causes the alternative to be set back and how I can avoid that?

Here is the log of what was upgraded. The only things that seem suspicious to me are ubuntu-drivers-common and xserver-xorg-video-intel:

/var/log/apt/history.log

Upgrade: oxideqt-codecs:amd64 (1.0.5-0ubuntu0.14.04.1, 1.1.2-0ubuntu0.14.04.1), libreoffice-pdfimport:amd64 (4.2.4-0ubuntu2, 4.2.6.3-0ubuntu1), libreoffice-base-core:amd64 (4.2.4-0ubuntu2, 4.2.6.3-0ubuntu1), libsystemd-login0:amd64 (204-5ubuntu20.4, 204-5ubuntu20.5), ure:amd64 (4.2.4-0ubuntu2, 4.2.6.3-0ubuntu
1), systemd-services:amd64 (204-5ubuntu20.4, 204-5ubuntu20.5), libreoffice-writer:amd64 (4.2.4-0ubuntu2, 4.2.6.3-0ubuntu1), firefox-locale-en:amd64 (31.0+build1-0ubuntu0.14.04.1, 32.0+build1-0ubuntu0.14.04.1), libreoffice-impress:amd64 (4.2.4-0ubuntu2, 4.2.6.3-0ubuntu1), uno-libs3:amd64 (4.2.4-0ubuntu2, 4.2.6
.3-0ubuntu1), libreoffice-avmedia-backend-gstreamer:amd64 (4.2.4-0ubuntu2, 4.2.6.3-0ubuntu1), librbd1:amd64 (0.80.1-0ubuntu1.1, 0.80.5-0ubuntu0.14.04.1), libreoffice-draw:amd64 (4.2.4-0ubuntu2, 4.2.6.3-0ubuntu1), ubuntu-drivers-common:amd64 (0.2.91.5, 0.2.91.6), fonts-opensymbol:amd64 (102.6+LibO4.2.4-0ubuntu
2, 102.6+LibO4.2.6.3-0ubuntu1), firefox:amd64 (31.0+build1-0ubuntu0.14.04.1, 32.0+build1-0ubuntu0.14.04.1), libreoffice-core:amd64 (4.2.4-0ubuntu2, 4.2.6.3-0ubuntu1), libsystemd-daemon0:amd64 (204-5ubuntu20.4, 204-5ubuntu20.5), libgudev-1.0-0:amd64 (204-5ubuntu20.4, 204-5ubuntu20.5), libreoffice-gnome:amd64 (
4.2.4-0ubuntu2, 4.2.6.3-0ubuntu1), libpam-systemd:amd64 (204-5ubuntu20.4, 204-5ubuntu20.5), librados2:amd64 (0.80.1-0ubuntu1.1, 0.80.5-0ubuntu0.14.04.1), libreoffice-presentation-minimizer:amd64 (4.2.4-0ubuntu2, 4.2.6.3-0ubuntu1), shotwell-common:amd64 (0.18.0-0ubuntu4.1, 0.18.0-0ubuntu4.2), udev:amd64 (204-5
ubuntu20.4, 204-5ubuntu20.5), shotwell:amd64 (0.18.0-0ubuntu4.1, 0.18.0-0ubuntu4.2), libreoffice-style-human:amd64 (4.2.4-0ubuntu2, 4.2.6.3-0ubuntu1), gir1.2-gudev-1.0:amd64 (204-5ubuntu20.4, 204-5ubuntu20.5), liboxideqtcore0:amd64 (1.0.5-0ubuntu0.14.04.1, 1.1.2-0ubuntu0.14.04.1), libudev1:amd64 (204-5ubuntu2
0.4, 204-5ubuntu20.5), libudev1:i386 (204-5ubuntu20.4, 204-5ubuntu20.5), libreoffice-help-en-us:amd64 (4.2.4-0ubuntu2, 4.2.6.3-0ubuntu1), libreoffice-ogltrans:amd64 (4.2.4-0ubuntu2, 4.2.6.3-0ubuntu1), xserver-xorg-video-intel:amd64 (2.99.910-0ubuntu1, 2.99.910-0ubuntu1.1), python3-uno:amd64 (4.2.4-0ubuntu2, 4
.2.6.3-0ubuntu1), libreoffice-common:amd64 (4.2.4-0ubuntu2, 4.2.6.3-0ubuntu1), libsystemd-journal0:amd64 (204-5ubuntu20.4, 204-5ubuntu20.5), libreoffice-gtk:amd64 (4.2.4-0ubuntu2, 4.2.6.3-0ubuntu1), liboxideqt-qmlplugin:amd64 (1.0.5-0ubuntu0.14.04.1, 1.1.2-0ubuntu0.14.04.1), libreoffice-math:amd64 (4.2.4-0ubu
ntu2, 4.2.6.3-0ubuntu1), libreoffice-calc:amd64 (4.2.4-0ubuntu2, 4.2.6.3-0ubuntu1), rsyslog:amd64 (7.4.4-1ubuntu2, 7.4.4-1ubuntu2.1)
2

3 Answers 3

4

Same here.

After some trial and error, downgrading ubuntu-drivers-common to 0.2.91.5 worked for me. Possibly reinstalling nvidia drivers (purge, then install) after this downgrade might be necessary.

5
  • Thanks! How did you downgrade it?
    – Ingo Bürk
    Commented Sep 4, 2014 at 9:19
  • 1
    Downloaded from launchpad.net/ubuntu/trusty/amd64/ubuntu-drivers-common/… , then sudo dpkg -i ubuntu-drivers-common_0.2.91.5_amd64.deb. If you don't clean your apt archives, you probably have ubuntu-drivers-common_0.2.91.5_amd64.deb file in /var/cache/apt/archives/. Commented Sep 4, 2014 at 10:02
  • Mh, I downgraded it, purged&installed nvidia again, changed the alternatives, logged back out and in – but it's still not working :/ The alternatives keep jumping back to the other setting.
    – Ingo Bürk
    Commented Sep 4, 2014 at 13:56
  • This worked for me. I couldn't go past splash screen whenever I had Nvidia drivers installed. Downgrading ubuntu-drivers-common from 0.2.91.6 to 0.2.91.4 solved the problem.
    – fabikw
    Commented Sep 8, 2014 at 1:51
  • I added some details to the implementation of this solution here
    – modulitos
    Commented Sep 8, 2014 at 6:19
0

It seems to be a problem with Optimus. I tried bumblebee as well as prime without any luck.

However, going into my BIOS and switching from Optimus to Discrete Graphics (only running the nvidia card), the nvidia driver is finally successfully loaded.

One question persists: Who or what is messing with the alternatives? It seems to happen everytime I log out.

If I switch to the virtual console in the login screen and change the alternatives there, I can log in and they don't change. Only when logging out they seem to revert back to the mesa entry.

0

Mine is working absolutely fine since upgrades from 2014-08-30 16:21 to 2014-09-07 14:08. I'm running:

  • kubuntu 14.04.1
  • nvidia-331 from xorg-edgers
  • never installed bumblebee on this machine
  • using nvidia-prime from beginning
  • weekly doing dist-upgrade
  • never do-release-upgrade

Before upgrade today I had the known problem with a black screen when starting xserver with nvidia card selected. This could be solved by switching to text-mode console and back. Now, this is not happening again. I noticed, that bbswitch module is now loaded by default on boot, but I had not put bbswitch or nvidia myself in /etc/modules. neither are they found there now. So, I guess this has to do with the heavy work and frequent releases to mesa, mayland, xserver, video-nouveau and video-intel during the last month. Now the new kernel seems to load any bbswitch, nvidia during boot on its own. I hope this is the beginning of a working mainstream mayland and kms system for ubuntu. Thanks!

My suggestions:

  • uninstall bumblebee
  • select ppa xorg-edgers
  • install nvidia (nvidia-331 is current stable, I haven't seen big differences between 337, so choosing 331 while developing with cuda 6.0 on my GTX-880M)
    • before must purge nvidia*
    • be sure nouveau is not loaded after boot (Since 14.04 I had no reason to do it manually but it should be done by apt install scripts)

Other suggestions:

  • I always did upgrading when nvidia-prime was selected nvidia card, so maybe some upgrades detect the card and install dkms modules or configure correctly on installation

Tell me if you need more detailed infos.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .