I have just got a ThinkPad L520 and my first step, naturally, is to install Ubuntu. I've got the 11.04 amd64 Alternate CD, but every time I run anything from the first menu I just get a blank screen.

The weird thing is, I tried the i386 live disk and it loads fine, but I have 6GB RAM and would rather use it all :)

There are no error messages or anything of the kind displayed, it simply freezes on a blank screen and I have to do a hard-reset.

I have tried an Oneiric amd64 Desktop Daily, but it suffers from the same problem.

I also tried 10.04.02 LTS amd64, which installed and appeared to work (although it didn't support the widescreen or wireless card). After an upgrade to 10.10, it stopped working. Booting into the newer Kernel resulted in a blank screen, while booting into the older Kernel only gives me a console.
BLANK SCREEN - 2.6.35-30-generic
CONSOLE ONLY - 2.6.32-28-generic

Does anyone have any ideas what I can do to get this working?

I originally thought my problem was similar to the one mentioned in this question, but I have tried this under my console-only install of 10.10 with no luck.

  • Trying to boot with nomodeset from the installer just shows a black screen still.
  • Any of these options get the installer to work: acpi=off, noapic & nolapic
  • @Jorge Castro, nomodeset doesn't do anything, but any of these options work: acpi=off, noapic & nolapic. What do these options do, and what sort of downsides are there from using them?
    – Stephen RC
    Jul 6, 2011 at 23:48
  • I'm installing at the moment, with noapic turned on. I will write up a question about it now :)
    – Stephen RC
    Jul 7, 2011 at 0:11

5 Answers 5


Using any of these Boot Options allows the installer to work: acpi=off, noapic & nolapic.

I have posted another question asking about what they do and problems associated with them.


This workaround worked for a number of German Ubuntu users (including myself) with a Lenovo L520.

  1. Get a the appropriate live cd of Ubuntu (i used x64)

  2. Install Ubuntu using Live Cd (this should work)

  3. Restart try to boot, should result broken screen

  4. Boot into the live cd

  5. Close Lid, laptop goes into stand by and Open Lid again, screen should be fine now, login in now

  6. mount your /boot partition

  7. Edit your grub settings (of the installed ubuntu) by sudo gedit /etc/default/grub

  8. change: #GRUB_TERMINAL=console to GRUB_TERMINAL=console and save

  9. Update grub using: sudo update-grub

  10. Reboot

Now everything should working fine.


I suggest to install the system using the Ubuntu Alternate install CD, which has a textual installer.

Then, if you have problems starting the installed system in graphical mode, you can start the system in recovery mode, modify grub as you say and see if it works.

  • I've tried that one, the Alternate Installer won't even start. (My post did say "I've got the 11.04 amd64 Alternate CD")
    – Stephen RC
    Jul 6, 2011 at 20:34
  • @Valorin: sorry, I didn't see. But so I cannot agree that your situation is similar to that other question.
    – enzotib
    Jul 6, 2011 at 20:37
  • Yeah, I think it's different. I got 10.04 LTS installed, but an upgrade to 10.10 broke it. I tried setting that flag in GRUB, but it hasn't helped. I'll update my question.
    – Stephen RC
    Jul 6, 2011 at 20:49

Valorin: I got exactly the same symptoms with my Lenovo L520 with Intel i7 Sandy Bridge.

I got it fixed like this:

  1. Fixed the booting issue by adding noapic to GRUB_CMDLINE_LINUX_DEFAULT option to GRUB loader as advised in your home page under "Blank Screen on Boot".

  2. After the starting of X (I use xfce4 and I could hear the sounds) showing nothing but green and red stripes in the screen I tried setting GRUB_GFXPAYLOAD_LINUX=text to /etc/default/grub as advised here and it "worked".

Now at the boot my system says "error: no video mode activated." But X and xfce4 runs normally.

Maybe someone could answer these questions:

  1. What exactly "error: no video mode activated." means after setting GRUB_GFXPAYLOAD_LINUX=text? What do I lose by setting that option?

  2. How setting noapic option affects the system? I mean is there some known issues which come after setting noapic?

  • This site does not work like a forum. Instead of asking questions in your answer it's suggested that you put your questions as a new question.
    – N.N.
    Sep 12, 2011 at 19:11

Installed Ubuntu 11.10 from iso on live cd to Lenovo E520 (64 bit) that had shipped direct from Lenovo.

Installation worked fine, but boot displays manufacturer screen with prompt to type enter to interrupt normal startup and then goes to black screen.

After hard reboot (i.e. power button) system boots normally by displaying GUI with uid and password prompt.

Sometimes more than one hard reboot is needed.

The "suspend" and "hibernate" options seem to cause same problem.

(After boot and reboot, then few other problems spotted so far except jumpy cursor when typing fast. Unrelated and strange but . . . .)

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .