0

I was able to create a Ubuntu guest under PowerKVM and installed 14.04.1 on it.

I set up ssh, telnet and set things up so I could log into the root account

Then I installed the LDAP client and tried to log in to one of the ldap accounts but get failures that look to be from a library reference in authentication (pam?/python?)

All of the following detail (bad things) happen when I set authentication to LDAP in the /etc/nsswitch.conf file.

If I remain using local accounts, logins, etc things work just fine.

1 - Most importantly, if I reboot, the system hangs with the following message in the console

 /usr/bin/python3: symbol lookup error: /lib/powerpc64le-linux-gnu/libnss_ldap.so.2: undefined symbol: __libc_lock_lock

2 - If I su to the account -

su - metheuser
Segmentation fault

3 - If I SSH or telnet to the server, the following message shows up in the syslog file

kernel: [  146.489209] su[1000]: unhandled signal 11 at 00003fffb6434000 nip 00003fffb64062d4 lr 00003fffb6406298 code 30001

My problem is that I need to set it up for LDAP authentication and automount through LDAP but am having issues. Where do I start?

1

Turns out to be a regression bug in PowerKVM.

An update to PowerKVM is expected in the coming weeks - we can be contacted on DeveloperWorks if a fix is desired sooner. https://www.ibm.com/developerworks/group/tpl

There is no work-around known... LDAP is not typically a common-case..

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.