0

I have encountered a problem, that I have never before encountered. I have a Nashua 8GB USB flash drive that I have formatted for different purposes many times.

Recently I wanted to format it to NTFS and transfer a movie to it so I could watch it on my smartTV. Something I have done before with no problems. For some reason, the formatting process stops (as in just stays at the same percentage completed on the load bar indefinitely) while I was formatting it with the default Disks tool in Ubuntu 12.04. Eventually I just cancel the formatting and it unmounts and disappears from the list of media in the Disks tool. I pull out the flash drive and insert it again. It seems to work and it appears that the drive has actually been formatted to NTFS, so I just decide to start transferring the movie. It fails, and I end up trying to format it again with no luck.

Everytime I insert it initially Nautilus tries to read it and gives me Sorry, could not display all the contents of "usb-USB_DISK2.0.....": Error when getting information for file "/mnt/usb-USB_DISK2.0...../movie.mkv":input/output error

Everytime I attempt to format it with Disks tool it gives me Error wiping device: Command-linewipefs -a "/dev/sdb1" exited with non-zero exit status 1:wipefs:error:/dev/sdb1:probing initialization failed (udisks-error-quark, 0)

I have tried with GParted, but had no luck with that either. Gave practically the same error. I have also tried various terminal commands suggested on this forum for similar problems. Unfortunately don't remember exactly which.

Anyone got any ideas? Any suggestions will be appreciated.

0

Last time I couldn't mount/format a USB drive in Linux, I just used Windows. For some reason, Windows just has better USB support. You may want to use CheckDisk to see if there are any disk errors.

  • I will try that. I guess I can borrow a windows machine from someone. Thank you. – Kenneth Petersen Sep 4 '14 at 13:08
  • It is possible to render a flash drive unusable just by unplugging it too soon. – john kieran Sep 7 '14 at 15:53
0

Solid state drives slowly wear-out so it is possible that it got down in some parts. If this is the case the command shall revive surviving blocks so you can use it, although with less space:

$ sudo badblocks -svw /dev/<device name>

Please note that it will destroy the whole content of the drive.

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.