4

I recently updated my kernel to 3.13.0-35-generic,after update my elantech touchpad multi touch stopped working

I tried fixing it from here https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1166442/+index?comments=all

But still its not working,I am using ubuntu 14.04,lenovo z510.

2
  • What exactly did you try?
    – Jan
    Sep 3 '14 at 19:56
  • @jan I updated my question
    – Lohith MV
    Sep 4 '14 at 8:39
2

Fix the kernel 3.13

You can try the patch attached to the bug in Launchpad. So first, download the patch and:

cd /path/to/destination/folder

Before to install the patch you may need to install the package dkms using the command:

sudo apt-get install dkms

Then, install the patch:

sudo dkms ldtarball psmouse-elantech-x551c.tar.gz
sudo dkms install -m psmouse -v elantech-x551c

After it's installed successfully, you need to remove and re-add the module from, and to the kernel:

sudo rmmod psmouse
sudo modprobe psmouse

Finally, to make changes permanent on boot:

sudo update-initramfs -u -k all

The patch works but disables the physical right-click, so I decided to upgrade the kernel.

Upgrade to newer kernels (e.g. 3.16)

Trying new kernels is not much difficult. All you need is 3 .deb files from kernel mainline : two linux-headers and linux-image (both of them from either generic or lowlatency) suitable for your architecture and one linux-headers-*-all; for example 3.16 for a 64-bit system will be:

linux-headers-3.16.0-031600-generic_3.16.0-031600.201408031935_amd64.deb     
linux-headers-3.16.0-031600_3.16.0-031600.201408031935_all.deb
linux-image-3.16.0-031600-generic_3.16.0-031600.201408031935_amd64.deb

You can install them from Software Center, or by commands:

cd /path/to/download/folder
sudo dpkg -i linux*.deb

Then you need to update grub settings:

sudo update-grub

Restart the system to see if the kernel works. Be aware that proprietary drivers may have problems with new kernels. In the case of your system failed to boot properly, go to boot advanced option, select a working kernel to boot. Then remove the non-working kernel, the same example here:

sudo apt-get remove linux-headers-3.16.0-* linux-image-3.16.0-*

And update grub again with sudo update-grub.

Edit: It is safer to install kernel packages from Ubuntu repositories with Software Center or Synaptic Package Manager. There are four files of each version; for example, for the latest build of 3.16:

  • linux-headers-3.16.0-28
  • linux-headers-3.16.0-28-generic
  • linux-image-3.16.0-28-generic
  • linux-image-extra-3.16.0-28-generic
6
  • its started working,Thanks a lot,Just out of curiosity what was I missing? did patch got updated ?
    – Lohith MV
    Oct 28 '14 at 14:03
  • @user422543, you only missed update-initramfs to prevent changes lost after reboot. Furthermore, the patch can have side effects (i.e. broken physical right-click) so I added the update kernel part. But if you mean my edit on your question, well, you just posted the answer inside the question itself. Sorry! I should leave it to you to do on yourself.
    – AliN
    Oct 28 '14 at 14:29
  • I just tried first part didn't do the kernel update part and regarding "putting answer inside question" I tried all the steps i posted it didn't work for me before and now I am surprised to see its started working
    – Lohith MV
    Oct 28 '14 at 18:13
  • I just have one quick question I didn't do update initramfs I might lose the changes after update thats fine but you said you might lose rt click that happens because of patch or because of the last cmd update initramfs ?
    – Lohith MV
    Oct 28 '14 at 18:19
  • @user422543 because of the patch.
    – AliN
    Oct 29 '14 at 0:45
1

Do a: sudo modprobe -r psmouse and sudo modprobe psmouse proto=imps

The right button then will start working.

0
1

On my Acer E15 with ubuntu 14.04, kernel 3.16.0-31-generic, I had to set the touchpad to Basic in the BIOS. Else the Elantic touchpad did not work at all. But, it did not work well, no scrolling, etc.. But, after having patched the kernel as described above, it worked fine including right-click.

I have an X-config file /etc/X11/xorg.conf - though I have not checked whether it matters.

Section "InputClass"
           Identifier "ETPS/2 Elantech Touchpad"
           MatchProduct "ETPS/2 Elantech Touchpad"
           MatchDevicePath "/dev/input/event*"
           Driver "synaptics"
           Option "TapButton1" "1"
           Option "TapButton2" "3"
           Option "TapButton3" "2"
           Option "VertTwoFingerScroll" "1"
           Option "HorizTwoFingerScroll" "1"
           Option "CoastingSpeed" "10"
           Option "EdgeMotionMinZ" "30"
           Option "EdgeMotionMaxZ" "40"
           Option "EdgeMotionMinSpeed" "100"
           Option "EdgeMotionMaxSpeed" "400"
           Option "FingerLow" "9"
           Option "FingerHigh" "12"
           Option "EmulateMidButtonTime" "0"
           Option "ClickPad" "True"
           Option "SoftButtonAreas" "50% 0 82% 0 0 0 0 0" 
EndSection
1
1

had the same issue try this..

sudo apt-get install xserver-xorg-input-synaptics
0

Type sudo modprobe psmouse proto=imps The right button should work.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.