0

I am trying to build an application that requires the phonon library...

I got an error because the lphonon was not found. so I tried to look for it... there is no "phonon" on my system.

I tried installing it

sudo apt-get install libqt4-phonon sudo apt-get install libqt4-phonon-dev

neither worked, so I tried

sudo apt-get install phonon

It worked... and i was able to find it in

\usr\lib\i386-linux-gnu

, but the files i find are

libphonon.so.4 and libphonon.so.4.6.0

I added this path in the project file

unix:INCLUDEPATH += /usr/lib/i386-linux-gnu

this was there before

unix:QT += phonon

Do I have to change the name of the lib ? How can I make it work ?

0

On my system there isn't this package, but thee is something available called libphonon4qt5. I suggest you go into synaptic, search for phonon and pick the package you need.

  • Thank you i was just updating my question... I was able to download... something but I don't know if it is right... I must use qt4. – Thalia Sep 3 '14 at 16:06
0

The only thing that finally worked was to install the deb package myself...

https://packages.debian.org/sid/libphonon-dev

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.