18

I'm using Ubuntu 14.04 with gnome classic.

I want to add 4 workspaces. I right click into the workspaces (left-bottom) and go to preferences. I change the number of workspaces from 1 to 4 and close the window. No workspaces are added and when I press to preferences again, I see a 1 not a 4.

23

Do you mean gnome-session-flashback instead of gnome classic ? If yes, you can do that by installing the compizconfig settings manager and plugins packages, i.e.

sudo apt-get install compizconfig-settings-manager compiz-plugins

You need to start the compizconfig settings manager found under

Appications -> System Tools -> Preferences

Once loaded, click on General Options and the Desktop Size tab to set the workspaces.

2
  • 1
    The plugin "Desktop Wall" offers keyboard binings for workspace switching.
    – jnas
    Feb 5 '16 at 7:44
  • Though vertical size not working, if Desktop Wall is not enabled May 19 '16 at 8:06
11

Install CompizConfig Settings Manager:

sudo apt-get install compizconfig-settings-manager compiz-plugins

After installing CompizConfig Settings Manager it should be:

Appications -> System Tools -> Preferences -> CompizConfig Settings Manager

A window will appear, accompanied by a Warning dialog. Click OK on the warning dialog.

Double-click General options on the other window.

Now click on Desktop Size. The default value is 1 (horizontal) x 1 (vertical). Change to whatever you would like to have. I chose 2 x 2 which was what I wanted, and it worked perfectly!

2
  • CompizConfig Settings Manager is not installed by default
    – CommandZ
    Jul 29 '15 at 15:25
  • This is exactly how it worked for me under 14.04.
    – RoraΖ
    Sep 28 '15 at 13:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.