3

I can't activate my gpu when running Ubuntu 14.04.

I've tried to follow the steps here but without any luck. http://xpressrazor.wordpress.com/2013/10/08/enable-and-use-open-source-radeon-drivers-in-a-muxless-hybrid-graphics-intelamd-setup/

The output of cat /sys/kernel/debug/vgaswitcheroo/switch always return that my discrete card is in the DynOff state and I can't switch between them.

$ cat /sys/kernel/debug/vgaswitcheroo/switch
0:IGD:+:Pwr:0000:00:02.0
1:DIS: :DynOff:0000:01:00.0

Also, as my card is not supported by ATI so the installation of the proprietary drivers is not an option, at least as far as I'm aware.

$ lspci -nn | grep VGA      
00:02.0 VGA compatible controller [0300]: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller [8086:0116] (rev 09)
01:00.0 VGA compatible controller [0300]: Advanced Micro Devices, Inc. [AMD/ATI] Whistler [Radeon HD 6730M/6770M/7690M XT] [1002:6740] (rev ff)

$ xrandr --listprovidersProviders: number : 1
Provider 0: id: 0x47 cap: 0x9, Source Output, Sink Offload crtcs: 3 outputs: 5 associated providers: 0 name:Intel

Is there any way to enable my discrete card?

3

Don't know how and why, but after some tries I was able to install the proprietary AMD drivers and the AMD Catalyst Control Center successfully. However, only the drivers from fglrx-updates worked. After several attempts (and reboots) I was able to configure the amd graphics (using the command amdconfig --adapter=all --initial) and now I can switch between the integrated and discrete video cards, which is quite awesome! Finally I am able to use my AMD graphics on Ubuntu.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.