I'm using Ubuntu 11.04, and I'm trying to install TortoiseHg. I've applied the PPA from TortoiseHg's website, so that apt-get can actually find it. But whenever I type sudo apt-get tortoisehg, I get this:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 tortoisehg : Depends: mercurial (>= 1.8) but 1.7.5-1ubuntu1 is to be installed
E: Broken packages

I understand what this means: I need to install Mercurial 1.8. The problem is that I can't. If I try sudo apt-get install mercurial, it says that 1.7.5 is the latest version, which it most certainly isn't.

So how do I convince this thing to install a more recent version of Mercurial?

I tried the commands from this answer to install Mercurial, but that didn't help. It again said that Mercurial was up to date.


Use the mercurial PPA

apt-add-repository ppa:mercurial-ppa/releases
apt-get update 
apt-get install tortoisehg
  • I used this for Ubunut 18.04 too and it worked fine. – user1015214 Jan 11 '19 at 14:41
  • doesn't work for 19.04 though. have to run sudo apt update --allow-unauthenticated && sudo apt install tortoisehg – tatsu May 21 '19 at 12:54
  • This no longer works with Ubuntu 20 or Mint 20 – AndrewWhalan Jul 6 '20 at 1:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.