30

OS: Ubuntu 13
Printer: HP Deskjet 2540

Problem: Printer worked initially. Suddenly stopped working. Printer cue just says "pending" and printing never happens.

How do I get it to go from "pending" to "printing"?

1
  • FWIW, I got this problem under vanilla Debian, printer status just suddenly started showed "Pending - Printer error", and it was not possible to get any other detailed print status. Then I read this and went into Printer Settings and sure enough the printer Enabled checkbox was not enabled... clicking it printed the document... great system.... :) – BjornW Feb 5 '18 at 17:15
53
+50

I found the problem. Under Settings>Printers>Policies "Enabled" was not selected. Why is this even an option?? Of all the features that used to make Ubuntu a good operating system have been stripped away, this one remains?? Unreal.

10
  • 3
    That did the trick. I'm with you, it's a ridiculous option and the point is that I didn't do anything to have it disabled... – cabreracanal Sep 15 '15 at 18:37
  • 3
    +1. Doesn't make sense that this Enabled option is not visible in Printing Status tool window. – IsaacS Jan 3 '16 at 0:58
  • 4
    +1 This resolved my issue even though I had already printed something out 10 mins earlier. So don't be shy to check this setting as it might be your issue. – James Feb 21 '16 at 22:00
  • @cabreracanal This is such a strange bug.. The printer was working, and all of a sudden this bug kicks in.. What the...? Good thing it was this easy to fix.. But how did such a bug come into existence in the first place? – Fiksdal May 6 '16 at 10:32
  • 1
    Just wanted to note - to access this on Ubuntu 14.04: run system-config-printer; in the Printers dialog, select your printer, right-click, choose Properties; the Printer Properties dialog is started with the "Settings" tab on the left selected; the "Policies" tab is right below it - select "Policies" tab, and then can see the "Enabled" setting. – sdaau Jan 18 '18 at 19:23
5
  • sudo system-config-printer

  • right click printer icon in Printers - localhost

    /properties
    /settings
    /policies

  • check "enabled"

  • close the system-config-printer tool

done.

1
  • Nope, did all that. It's enabled fine, that's not the proble. Just, print q pending. Hintr: recently I cancelled a job which was printing voluminous unwanted stuff. Thereafter, "pending". Power cycle, add delete bla. Still "pending". I'll try again to remove thre printer and add it in again. – user289334 May 12 '20 at 14:04
2

Under Ubuntu 16.04 the same problem occurred, on my networked (wireless) HP 4635, in the same way: suddenly, without the user doing anything, and for no obvious reason. It was resolved in about the same way: click the Settings icon (gear), click System Settings, open Printers, right-click the printer, click "Enabled" in the printer's context menu to check-mark "Enabled". (If "Enabled" was already check-marked, this isn't your solution.)

0

Update to Donnie's answer:

For non-GUI CUPS user, you can adjust this setting in your CUPS web interface.

Administration => Manage Printers => Select your printer => Maintaince => Resume Printer.

It's really strange that, a single printing failure causes CUPS to prevent any further printing job. Bad design .

Not the answer you're looking for? Browse other questions tagged or ask your own question.