-1

I've downloaded dell ubuntu 12.04 drivers and un-tar the package. Then enter the approprite folder to install as specified in first and one answer this question. First i've installed it with double clicking and it gave an error after that removed it and install on terminal again and it gave the same error again. Terminal output;

root@dell-p-m4800:/media/DATA/Linux - Yedek/M4800_M6800_A03.fish.tar/M4800_M6800_A03.fish/debs# dpkg -i bcmwl-kernel-source-dw1550.deb
Selecting previously unselected package bcmwl-kernel-source.
(Reading database ... 467738 files and directories currently installed.)
Unpacking bcmwl-kernel-source (from bcmwl-kernel-source-dw1550.deb) ...
Setting up bcmwl-kernel-source (6.30.223.64somerville1) ...
Loading new bcmwl-kernel-source-6.30.223.64somerville1 DKMS files...
First Installation: checking all kernels...
Building only for 3.13.0-35-generic
Building for architecture x86_64
Building initial module for 3.13.0-35-generic
Error! Bad return status for module build on kernel: 3.13.0-35-generic (x86_64)
Consult /var/lib/dkms/bcmwl-kernel-source/6.30.223.64somerville1/build/make.log for more information.
dpkg: error processing bcmwl-kernel-source (--install):
 subprocess installed post-installation script returned error exit status 10
Errors were encountered while processing:
 bcmwl-kernel-source

make.log file;

DKMS make.log for bcmwl-kernel-source-6.30.223.64somerville1 for kernel 3.13.0-35-generic (x86_64)
Tue Sep  2 22:42:24 EEST 2014
make -C /lib/modules/3.13.0-35-generic/build M=/var/lib/dkms/bcmwl-kernel-source/6.30.223.64somerville1/build modules
make[1]: Entering directory `/usr/src/linux-headers-3.13.0-35-generic'
CFG80211 API is prefered for this kernel version
Using CFG80211 API
  CC [M]  /var/lib/dkms/bcmwl-kernel-source/6.30.223.64somerville1/build/src/shared/linux_osl.o
  CC [M]  /var/lib/dkms/bcmwl-kernel-source/6.30.223.64somerville1/build/src/wl/sys/wl_linux.o
/var/lib/dkms/bcmwl-kernel-source/6.30.223.64somerville1/build/src/wl/sys/wl_linux.c: In function ‘wl_tkip_printstats’:
/var/lib/dkms/bcmwl-kernel-source/6.30.223.64somerville1/build/src/wl/sys/wl_linux.c:3237:7: warning: passing argument 1 of ‘wl->tkipmodops->print_stats’ from incompatible pointer type [enabled by default]
       wl->tkip_bcast_data[idx]);
       ^
/var/lib/dkms/bcmwl-kernel-source/6.30.223.64somerville1/build/src/wl/sys/wl_linux.c:3237:7: note: expected ‘struct seq_file *’ but argument is of type ‘char *’
/var/lib/dkms/bcmwl-kernel-source/6.30.223.64somerville1/build/src/wl/sys/wl_linux.c:3240:4: warning: passing argument 1 of ‘wl->tkipmodops->print_stats’ from incompatible pointer type [enabled by default]
    wl->tkipmodops->print_stats(debug_buf, wl->tkip_ucast_data);
    ^
/var/lib/dkms/bcmwl-kernel-source/6.30.223.64somerville1/build/src/wl/sys/wl_linux.c:3240:4: note: expected ‘struct seq_file *’ but argument is of type ‘char *’
/var/lib/dkms/bcmwl-kernel-source/6.30.223.64somerville1/build/src/wl/sys/wl_linux.c: In function ‘wl_reg_proc_entry’:
/var/lib/dkms/bcmwl-kernel-source/6.30.223.64somerville1/build/src/wl/sys/wl_linux.c:3461:2: error: implicit declaration of function ‘create_proc_entry’ [-Werror=implicit-function-declaration]
  if ((wl->proc_entry = create_proc_entry(tmp, 0644, NULL)) == NULL) {
  ^
/var/lib/dkms/bcmwl-kernel-source/6.30.223.64somerville1/build/src/wl/sys/wl_linux.c:3461:22: warning: assignment makes pointer from integer without a cast [enabled by default]
  if ((wl->proc_entry = create_proc_entry(tmp, 0644, NULL)) == NULL) {
                      ^
/var/lib/dkms/bcmwl-kernel-source/6.30.223.64somerville1/build/src/wl/sys/wl_linux.c:3466:16: error: dereferencing pointer to incomplete type
  wl->proc_entry->read_proc = wl_proc_read;
                ^
/var/lib/dkms/bcmwl-kernel-source/6.30.223.64somerville1/build/src/wl/sys/wl_linux.c:3467:16: error: dereferencing pointer to incomplete type
  wl->proc_entry->write_proc = wl_proc_write;
                ^
/var/lib/dkms/bcmwl-kernel-source/6.30.223.64somerville1/build/src/wl/sys/wl_linux.c:3468:16: error: dereferencing pointer to incomplete type
  wl->proc_entry->data = wl;
                ^
cc1: some warnings being treated as errors
make[2]: *** [/var/lib/dkms/bcmwl-kernel-source/6.30.223.64somerville1/build/src/wl/sys/wl_linux.o] Error 1
make[1]: *** [_module_/var/lib/dkms/bcmwl-kernel-source/6.30.223.64somerville1/build] Error 2
make[1]: Leaving directory `/usr/src/linux-headers-3.13.0-35-generic'
make: *** [all] Error 2

there are some pointer or type errors as far as I am concerned. How can I fix this problem? Must I change the code? Or is this a kernel version problem? Thanks.

2

It is a mismatch between the kernel version and the bcmwl-kernel-source version provided by Dell. I would suggest you try the official Ubuntu version in the repositories. With a temporary working internet connection:

sudo apt-get update
sudo apt-get install bcmwl-kernel-source

If this does not work, then do:

sudo apt-get remove bcmwl-kernel-source

Download this package to your desktop: http://mirrors.kernel.org/ubuntu/pool/restricted/b/bcmwl/bcmwl-kernel-source_6.30.223.141+bdcom-0ubuntu2_amd64.deb

Install it with:

sudo dpkg -i ~/Desktop/bcmwl*.deb
sudo modprobe wl
  • thanks @chili555 I did what you said but when I rebooted pc it lags on the ubuntu typed purple window and it didn't close I forced it to close by holdling the power buton then opened it (nothing was working). After these it shows me the same software installation error about bcmwl-kernel-source and wifi still does not working – Orkun Kasapoglu Sep 2 '14 at 21:23
  • Please see my edit. – chili555 Sep 2 '14 at 21:35
  • I removed bcmwl-kernel-source, downloaded other one and install with dpkg but after the install on terminal; 'code' DKMS: Install Completed 'code' still no other response from terminal, Control didn't turn to user on terminal, is this normal? – Orkun Kasapoglu Sep 2 '14 at 22:00
  • Yes, it is. After a reboot, is there any wireless? – chili555 Sep 2 '14 at 22:02
  • yes there is. I need reboot now and then sudo modprobe wl? – Orkun Kasapoglu Sep 2 '14 at 22:04

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.