1

I have been having problems running logisim on Ubuntu. At first it worked fine but now it just gets stuck "creating a file..." when I run the program. I've tried downloading another .jar and running... nothing

Its been like this for over 1h..

enter image description here

1

The stack trace in your console implies that it's an issue with the Java applet itself. Which leads to a few possible answers to your issue:

  1. It's an issue with the Logisim application itself. Maybe it's not compatible with a Linux operating system, or maybe it's not compatible with your version of java....

  2. The program needs to be run with elevated privileges (doubtful) or be run in a location where it can write to (more likely). Try making a folder for it somewhere in your home directory and running it within that directory

  3. It's an issue with the version of java you're using. Some java apps cannot use the open-jdk, and must instead use the oracle jdk. Typing java -version into console should tell you what version of java you have. If you have openjdk installed you can remove it and install oracle jdk by doing the following:

    sudo apt-get remove --purge openjdk*
    sudo apt-get install python-software-properties
    sudo add-apt-repository ppa:webupd8team/java
    sudo apt-get update
    sudo apt-get install oracle-java7-installer
    

    (replace the 7 in that last line with 6 or 8 if you'd rather have those versions).

You may also need to downgrade your version of java, which you can do by downloading one of the old versions from this page.

1

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.