0

I was logging into my ubuntu machine till last night. Today I had an error unknown group ID error for the group I was in and also the UID. But I had no errors till the last night. I lost my sudo access too. I can ssh into my machine and account but when I log in to through GUI I get a blank screen and Then I added the group ID to /etc/group. I can't login after editing them. karthik.singaravelan is my username here. Here are the /etc/group and /etc/passwd files

root:x:0:karthik.singaravelan
daemon:x:1:
bin:x:2:
sys:x:3:
adm:x:4:aspire
tty:x:5:
disk:x:6:
lp:x:7:
mail:x:8:
news:x:9:
uucp:x:10:
man:x:12:
proxy:x:13:
kmem:x:15:
dialout:x:20:
fax:x:21:
voice:x:22:
cdrom:x:24:aspire
floppy:x:25:
tape:x:26:
sudo:x:27:aspire
audio:x:29:pulse
dip:x:30:aspire
www-data:x:33:
backup:x:34:
operator:x:37:
list:x:38:
irc:x:39:
src:x:40:
gnats:x:41:
shadow:x:42:
utmp:x:43:
video:x:44:
sasl:x:45:
plugdev:x:46:aspire
staff:x:50:
games:x:60:
users:x:100:
nogroup:x:65534:
libuuid:x:101:
crontab:x:102:
syslog:x:103:
fuse:x:104:
messagebus:x:105:
bluetooth:x:106:
scanner:x:107:
colord:x:108:
lpadmin:x:109:aspire
ssl-cert:x:110:
lightdm:x:111:
nopasswdlogin:x:112:
netdev:x:113:
whoopsie:x:114:
mlocate:x:115:
ssh:x:116:
avahi-autoipd:x:117:
avahi:x:118:
pulse:x:119:
pulse-access:x:120:
utempter:x:121:
rtkit:x:122:
saned:x:123:
aspire:x:1000:
sambashare:x:124:aspire
mysql:x:125:
rabbitmq:x:126:
mongodb:x:127:mongodb
memcache:x:128:
tomcat6:x:129:
karthik.singaravelan:x:1001:

/etc/passwd

root:x:0:0:root:/root:/bin/bash
daemon:x:1:1:daemon:/usr/sbin:/bin/sh
bin:x:2:2:bin:/bin:/bin/sh
sys:x:3:3:sys:/dev:/bin/sh
sync:x:4:65534:sync:/bin:/bin/sync
games:x:5:60:games:/usr/games:/bin/sh
man:x:6:12:man:/var/cache/man:/bin/sh
lp:x:7:7:lp:/var/spool/lpd:/bin/sh
mail:x:8:8:mail:/var/mail:/bin/sh
news:x:9:9:news:/var/spool/news:/bin/sh
uucp:x:10:10:uucp:/var/spool/uucp:/bin/sh
proxy:x:13:13:proxy:/bin:/bin/sh
www-data:x:33:33:www-data:/var/www:/bin/sh
backup:x:34:34:backup:/var/backups:/bin/sh
list:x:38:38:Mailing List Manager:/var/list:/bin/sh
irc:x:39:39:ircd:/var/run/ircd:/bin/sh
gnats:x:41:41:Gnats Bug-Reporting System (admin):/var/lib/gnats:/bin/sh
nobody:x:65534:65534:nobody:/nonexistent:/bin/sh
libuuid:x:100:101::/var/lib/libuuid:/bin/sh
syslog:x:101:103::/home/syslog:/bin/false
messagebus:x:102:105::/var/run/dbus:/bin/false
colord:x:103:108:colord colour management daemon,,,:/var/lib/colord:/bin/false
lightdm:x:104:111:Light Display Manager:/var/lib/lightdm:/bin/false
whoopsie:x:105:114::/nonexistent:/bin/false
avahi-autoipd:x:106:117:Avahi autoip daemon,,,:/var/lib/avahi-autoipd:/bin/false
avahi:x:107:118:Avahi mDNS daemon,,,:/var/run/avahi-daemon:/bin/false
usbmux:x:108:46:usbmux daemon,,,:/home/usbmux:/bin/false
kernoops:x:109:65534:Kernel Oops Tracking Daemon,,,:/:/bin/false
pulse:x:110:119:PulseAudio daemon,,,:/var/run/pulse:/bin/false
rtkit:x:111:122:RealtimeKit,,,:/proc:/bin/false
speech-dispatcher:x:112:29:Speech Dispatcher,,,:/var/run/speech-dispatcher:/bin/sh
hplip:x:113:7:HPLIP system user,,,:/var/run/hplip:/bin/false
saned:x:114:123::/home/saned:/bin/false
aspire:x:1000:1000:aspire,,,:/home/aspire:/bin/bash
sshd:x:115:65534::/var/run/sshd:/usr/sbin/nologin
mysql:x:116:125:MySQL Server,,,:/nonexistent:/bin/false
rabbitmq:x:117:126:RabbitMQ messaging server,,,:/var/lib/rabbitmq:/bin/false
mongodb:x:118:65534::/home/mongodb:/bin/false
memcache:x:119:128:Memcached,,,:/nonexistent:/bin/false
tomcat6:x:120:129::/usr/share/tomcat6:/bin/false
karthik.singaravelan:x:1001:1001::/home/karthik.singaravelan:/bin/sh

output of id karthik.singaravelan

uid=1001(karthik.singaravelan) gid=1001(karthik.singaravelan) groups=1001(karthik.singaravelan),0(root),1352140539(power^users),1352554700(linux),1352139265(domain^users)

Is there any error with the config files that lets me not to log in? Other users can log in from my machine and I can log in from others machines. Whenever I press enter to login it goes black and returns to the screen. Kindly help me on this issue.

15
  • Are you using LDAP or something like that? Your groups has entries which are not in /etc/group.
    – muru
    Sep 2, 2014 at 11:41
  • @muru I am in my workplace. So they might have installed it. Will deleting the user and logging in again solve the problem?
    – Wordzilla
    Sep 2, 2014 at 11:44
  • They said something is wrong with configuration file and format everything. I have a lot of softwares installed in it that will take a day to install. However others can login from my machine and I can login from others @muru
    – Wordzilla
    Sep 2, 2014 at 11:53
  • Ok, so what happens exactly when you log in? Does it loop back to the log in screen? Does it remain stuck? Does it give an error?
    – muru
    Sep 2, 2014 at 11:56
  • It goes black for few seconds and returns to the log in screen. Ubuntu 12.04. I had executed usermod -u 1352568422 karthik.singaravelan useradd -u 1352568422 karthik.singaravelan useradd -s 1352568422 karthik.singaravelan useradd -s root karthik.singaravelan adduser karthik.singaravrlan
    – Wordzilla
    Sep 2, 2014 at 11:58

1 Answer 1

0

The Xauthority file was pointing to a group that doesn't exist and thus stuck at the login. I SSHed into my machine and removed the .Xauthority file, logging out and logging in creates a new Xauthority file with relevant permissions and thus logs into the account. Thanks @muru a lot for helping me on this issue. Also setting the Xauthority file to another existing group will solve this issue.

Not the answer you're looking for? Browse other questions tagged or ask your own question.