Years and years ago, a client of mine had a dying Windows NT Server 4.0 box that was really only used as a file server. I replaced it with SuSE and Samba (it's been so long, I no longer remember version numbers - or even years) and gave the local power user a shortcut to SWAT and instructions on how to resolve connection conflicts.

A couple of years ago, that machine was showing its age, and I replaced it with a 64-bit, dual-core machine running Ubuntu Server 9.04. Better in all sorts of ways - performance, simplicity of configuration, ease of setting up Samba to play nice with legacy apps (which was a huge nightmare when I was setting up SuSE!) - except: no SWAT!

Here's the situation: the main line-of-business app used to be a DOS/cTree database app; that program uses DOS SHARE (and its Windows successors) to handle file/record locking. In addition, certain utility functions (e.g. "Close the Day") require exclusive access to the database. SWAT gave the power user a way to see which stations had open connections to the database, and to kick them off if they were unresponsive.

Of course I've installed WebMin, and that gives me all the power that SWAT did - and a whole lot more, which is the problem. I can't make a shortcut directly to the Samba / connections section, so the user has to navigate the menu... and furthermore, there are a lot of options that the user doesn't need, and that I don't necessarily want her to have.

So far the solution has been that she calls me when there's an issue, and I log in to WebMin and resolve it. Also, they migrated to a much newer line-of-business app, and the old one is winding down. Still, though - is there anything that does (just) what I'm looking for (and nothing else)?

Edit: When I upgraded to Ubuntu 9.04, I did install SWAT, and I tried to use it. As the package summary warns, it did bad things; not only did it rearrange entries in my smb.conf, but Samba itself had been significantly updated relative to SWAT (I seem to recall that the issues had to do with oplock handling, which broke the DOS app), and nothing really worked anymore. Eventually I uninstalled SWAT, put my smb.conf back the way it had been, and used WebMin.

I hear and understand the suggestion that I update to a newer version of Ubuntu: I will do that as soon as I have the opportunity. But has SWAT been fixed? Has anyone actually used it recently? Because last time I tried it, it was not a good experience...

Update: I upgraded last night... what a nightmare that turned out to be! do-version-upgrade insisted on thinking I wanted to jump straight from Jaunty to Lucid (and of course insisting that I couldn't); eventually I just edited all of the sources from "jaunty" to "karmic" and did a full-upgrade. Then when I restarted, GRUB failed to start up with an Error 15 - turns out that it had added an extra "/boot" to the beginning of every entry in the list. Got that fixed; did a do-version-upgrade to Lucid... which broke HylaFax. (The bugtrackers claim that the problem's been fixed in Lucid, but it hasn't.) So I upgraded twice more to Natty, which fixed HylaFax... but somewhere along the way, smb.conf got trashed! But all's well that ends well, I guess. After all that, I didn't have the heart to try SWAT (considering the hash it made of things last time I tried it, in 2009); I'll try it in a day or two when I have time for experiments.

  • 1
    Its a shame you are using an unsupported server - swat is available from the repositories for the 5 year support 10.04 server.
    – fossfreedom
    Jul 5, 2011 at 18:59
  • Yes swat works @MT_Head :)
    – Rinzwind
    Jul 5, 2011 at 19:20
  • @Rinzwind - Out of curiosity, how recent is the newest version of SWAT? I was under the impression that the project had been abandoned.
    – MT_Head
    Jul 5, 2011 at 19:24
  • The one I posted is 11.04 since I am on 11.04! Can't get it much newer !?
    – Rinzwind
    Jul 5, 2011 at 19:29
  • 1
    I removed my answer since I am a strong believer of not advicing bad software ;) I have NOT found something like swat. @MT_Head
    – Rinzwind
    Jul 5, 2011 at 19:51

1 Answer 1


Why not install swat? It's in the repositories just a sudo apt-get install swat away...

Pre-post-edit: I've just noticed that you're running an unsupported version of Ubuntu. Support for 9.04 ended late last year. You can see the support schedules here.

This might explain (I'm not sure if they actually shut the repos off) why you can't access the package. You should consider moving up to at least 10.04 (a Long-term Support version) and that'll get you support up to late-2015. For business deployments where you don't want to shift platform versions all the time, you should always consider LTS versions.

So the fix:

  1. Update to a supported release
  2. Install swat
  3. Sit back and relax.

There's quite a bit of buy-in with that plan. You have to do two major upgrades to get to 10.04 and while I'd argue it's worth it for security (it is), there is a quicker, cheatier method: just grab the packages from a later release.

You can see and download the package available for Lucid here:

Once downloaded you just run:

sudo dpkg -i downloaded-package-name.deb

You might find you need to grab dependent packages too. Dpkg will inform you of missing dependencies.

This is not secure. This is sometimes dangerous. It might break Samba completely. Consider that a warning. Do things properly. Do an upgrade.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.