Something is wrong with Ubuntu Kernel and Windows DHCP,DNS Server.

First i will explain my problem in few words and then ill post all my configurations.

My ubuntu computer is behind a all-in-one Windows Server DHCP,DNS , Firewall.

My ubunut installation is not able to ping , traceroute , telnet some websites. Ive walk trough all the TCP/IP stack troubleshooting and im still not able to see what is wrong.

80-90 percent of other websites work good . Everything seems to get solved if i connect my computer directly to the router( a DSL connection)

I have other Linux and windows machines ( Centos and Windows 7) and they all work without any problem, is just with Ubuntu. Ive updated and reinstalled many times and still not getting the issue.

I even have tcpdump on the ubuntu machine and wireshark on the windows server and i see traffic coming in for all the working sites and failed requests for those who not.

Here is my ifconfig:

administrator@ubica-HP-Pavilion:~$ sudo ifconfig wlan1
wlan1     Link encap:Ethernet  HWaddr 00:90:4b:a2:4d:89  
      inet addr:  Bcast:  Mask:
      inet6 addr: fe80::290:4bff:fea2:4d89/64 Scope:Link
      RX packets:9397 errors:0 dropped:0 overruns:0 frame:0
      TX packets:4113 errors:0 dropped:0 overruns:0 carrier:0
      collisions:0 txqueuelen:1000 
      RX bytes:3284931 (3.2 MB)  TX bytes:536403 (536.4 KB)

Here is my route:

administrator@ubica-HP-Pavilion:~$ route
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
default         UG    0      0        0 wlan1     *        U     9      0        0 wlan1

Here is my /etc/hosts       localhost       ubica-HP-Pavilion

# The following lines are desirable for IPv6 capable hosts
::1     ip6-localhost ip6-loopback
fe00::0 ip6-localnet
ff00::0 ip6-mcastprefix
ff02::1 ip6-allnodes
ff02::2 ip6-allrouters

And the /etc/resolv.conf

# Dynamic resolv.conf(5) file for glibc resolver(3) generated by resolvconf(8)
search GPS.LOCAL

Ive changed DNS to Google's and OPENDNS's address and rebooted and nothing happens. Actually the non accesible site are resolved well, here is an example:

administrator@ubica-HP-Pavilion:~$ dig www.ubica.com.sv

; <<>> DiG 9.9.5-3-Ubuntu <<>> www.ubica.com.sv
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 35868
;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 1

; EDNS: version: 0, flags:; udp: 4000
;www.ubica.com.sv.      IN  A

www.ubica.com.sv.   86400   IN  A

;; Query time: 185 msec
;; WHEN: Mon Sep 01 19:10:48 CST 2014
;; MSG SIZE  rcvd: 61

And Pinging www.ubica.com.sv , gets resolved but it never answers ICMP requests:

administrator@ubica-HP-Pavilion:~$ ping www.ubica.com.sv
PING www.ubica.com.sv ( 56(84) bytes of data.
From icmp_seq=1 Destination Host Unreachable
From icmp_seq=2 Destination Host Unreachable
From icmp_seq=3 Destination Host Unreachable
From icmp_seq=4 Destination Host Unreachable
From icmp_seq=5 Destination Host Unreachable
From icmp_seq=6 Destination Host Unreachable
--- www.ubica.com.sv ping statistics ---
8 packets transmitted, 0 received, +6 errors, 100% packet loss, time 14148ms

and a traceroute to the same address pings back to itself:

administrator@ubica-HP-Pavilion:~$ traceroute www.ubica.com.sv
traceroute to www.ubica.com.sv (, 30 hops max, 60 byte packets
 1 (  2997.073 ms !H  2997.006 ms !H  2996.993 ms !H

If i ping or traceroute any other site it works fine:

administrator@ubica-HP-Pavilion:~$ ping www.godaddy.com
PING e8804.a.akamaiedge.net ( 56(84) bytes of data.
64 bytes from a96-17-125-116.deploy.akamaitechnologies.com ( icmp_seq=4 ttl=51 time=98.2 ms
64 bytes from a96-17-125-116.deploy.akamaitechnologies.com ( icmp_seq=5 ttl=51 time=101 ms

There are not IPtables entrys and the firewall is off:

administrator@ubica-HP-Pavilion:~$ sudo iptables -L
Chain INPUT (policy ACCEPT)
target     prot opt source               destination         

Chain FORWARD (policy ACCEPT)
target     prot opt source               destination         

Chain OUTPUT (policy ACCEPT)
target     prot opt source               destination 

administrator@ubica-HP-Pavilion:~$ sudo ufw status
Status: inactive

As i said before , Centos and Windows machines are able to access the same site without any trouble so i can probably discard the windows server. And as soon as i connect my ubuntu machine directly to the DSL it starts working without trouble.

Ive also checked using one of the IPs of the CentOS machines just to be sure that there is nothing blocking at IP level.

Here is the tcpdump of the ubuntu machine for interface when i try to ping a not workking host:

administrator@ubica-HP-Pavilion:~$ sudo tcpdump -c 10 -i wlan1 host verbose output suppressed, use -v or -vv for full protocol decode
listening on wlan1, link-type EN10MB (Ethernet), capture size 65535 bytes
19:27:39.586609 IP > 7253+ A? www.ubica.com.sv. (34)
19:27:40.200841 IP > 43428+ PTR? (42)
19:27:44.591912 IP > 7253+ A? www.ubica.com.sv. (34)
19:27:45.203612 IP > 43428+ PTR? (42)
19:27:45.391250 ARP, Request who-has tell, length 46
19:27:45.391327 ARP, Reply is-at 00:90:4b:a2:4d:89 (oui Unknown), length 28
19:27:45.405816 IP > 7253 1/0/0 A (50)
19:27:45.406365 ARP, Request who-has static-ip-209-239-120-202.inaddr.ip-pool.com tell, length 28
19:27:45.560263 ARP, Reply is-at 00:f4:28:00:29:a7 (oui Unknown), length 46
19:27:46.403509 ARP, Request who-has static-ip-209-239-120-202.inaddr.ip-pool.com tell, length 28
19:27:46.563522 ARP, Reply is-at 00:f4:28:00:29:a7 (oui Unknown), length 46
11 packets captured
24 packets received by filter
0 packets dropped by kernel

Please i need some more ideas in order to troubleshoot what is going on. Its not a single host trouble , it happens with many others i just used ubica.com.sv as an example.


  • Can you post more about your DNS client config details? And can you check this que page on domain/DNS? – JSBach Sep 2 '14 at 9:28
  • Could you post /etc/network/interfaces? Here is a useful link. – Lety Sep 2 '14 at 11:52
  • IMO, it's not a DNS problem. What looks strange to me here are those ARP requests: they ask for the MAC address of an host which can't be on the local network. Of course, there's no reply, and probably this is why the ping request fails. Now, how could happen ARP is told to ask for an host name ? – Pyrophorus Sep 2 '14 at 13:04
  • Actually there is nothing wrong with DNS , i can resolve any address by any method , ping , traceroute , dns , but after the ip has been resolved i can not achieve connectivity ( ping the IP ). As Pyrophorus said , im also suspicious about the ARP requests of a host that it is not in the local network , it should be redirected to the gateway. – Guillermo Sep 2 '14 at 23:17
  • Ive also tried adding a static ARP , and a static route for a specific host but it also fails. – Guillermo Sep 2 '14 at 23:19

From your ifconfig, I see that your MTU value is 1500. Try lowering it, first to 1492, then 1480 and so on and see if you can access the sites. Use

sudo ifconfig wlan1 mtu <new value> up

I had a similar problem and lowering my MTU value from 1500 to 1492 solved it.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.