10

For privacy and security reasons I want to disable the generation of any thumbnails in the ~/.cache/thumbnails folder (using Ubuntu 14.04 LTS).

I already tried this (without success):

  1. In the Filemanager "Files" (Edit ► Preferences) in the "Preview"-Tab I switched "Show Thumbnails" to "Never". Result: Thumbails are not shown in the filemanager but still be generated in the ~/.cache/thumbnails/normal/ folder when I open some pictures with the "Image Viewer" = FAIL!

  2. I used the dconf-editor and set org ► gnome ► desktop ► thumbnail-cache ► maximum-age to 0 and maximum-size to 0. Result: The same as the 1. try = FAIL!

  3. In the dconfeditor I set the option org ► gnome ► desktop ► thumbnailers ► disable-all. Result: Thumbnails of viewed pictures still be generated = FAIL!

A little bit weird solution I found is to delete the ~/.cache/thumbnails folder and than link it to /dev/null to avoid thumbnails are written to the hard disk:

rm -r ~/.cache/thumbnails && ln -s /dev/null ~/.cache/thumbnails

I really can't believe that this is the only solution to really disable the thumbnail generation!

2
  • You could deny permission to the folder to everyone except root? – Tim Sep 1 '14 at 21:42
  • Removing write permissions will results in some applications throwing an error when they try to write to that dir, for example GIMP. – isync Jan 7 '18 at 17:02
6

Thumbnails of specific file types can be disabled using dconf editor.

Install dconf editor:

Hit Alt+Ctrl+T and run the following command:

sudo apt-get install dconf-tools

Or search for "dconf-tools" in Software Center and install it from there.

How to disable thumbnails of specific file type?

Once installed, Hit super key (windows key) to open Unity dash and search for "dconf editor" and open it.

Navigate to org > gnome > desktop > thumbnailer

Paste the MIME type of PDF 'application/pdf' in the value field of disable key.

This will prevent Nautilus from generating thumbnails of PDF's in the future but old thumbnails will be there. To solve this you'll have to clear Nautilus thumbnail cache.

Open your home directory and Hit Ctrl+H to show the hidden files and folders. Open .thumbnails and delete all the files in it.

Restart your system or kill Nautilus for change to take effect.

To disable thumbnails for other file types, Add there MIME type in disable list as described above. Seprate multiple types with comma. like this:

['application/pdf','image/jpeg','video/mp4']

For complete list of MIME types visit iana.org.

2
  • 1
    How one can disable generation of all thumbnails, without playing whack-a-mole game? – reducing activity Jan 31 '17 at 9:01
  • 2
    @MateuszKonieczny There seems to be a disable-all boolean. It's description says Set to true to disable all external thumbnailer programs, independent on whether they are independently disabled/enabled.. Not sure what the external thumbnailers part means. – user3620828 Mar 18 '18 at 9:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.