8

I have tried all the forum threads here concerning this problem, none of the provided solutions worked (some even made the problem worse). I have an Asus x551m Laptop with SonicMaster audio. Ubuntu 14.04 worked fine with both the Headphones and internal speaker. After updating to 14.04.1, my headphone jack stopped working but the internal speaker is working fine.

  • Are the headphones working on another device? Want to rule out the hardware. Does the headphones work if you run Ubuntu of a live-USB? – Alvar Sep 1 '14 at 17:54
  • @Alvar The headphones work on all my other computers, and on the same computer running Windows 8.1. It seems that Ubuntu 14.04.1 is the only thing the headphone jack won't work with. – john kieran Sep 1 '14 at 18:02
  • Have you tried newer/older versions of the kernel? Since that's where most of the drivers are located.. – Alvar Sep 1 '14 at 18:19
  • As I said in my post, the headphone jack worked perfectly on 14.04, but after updating to 14.04.1 it stopped working. – john kieran Sep 1 '14 at 20:52
  • As I said in my comment, have you tried an older kernel. Because this sounds like a bug. Since it worked before. If it's a bug then report it so that it can be fixed. – Alvar Sep 1 '14 at 21:40
22

I spent a long time working with the same problem, based on lots of forum threads, and nothing helped. Then I tried this:

$ alsactl restore

That did it :)

  • this work for me! – Vitor Mazuco Nov 26 '15 at 23:20
  • Great, that helped me after messing with Audacity and audio inputs, which ended up in extreme feedback that I thought completely damaged my hardware. I was having constant white noise from the headphone mic, and it would not detect headphones. alsactl restore fixed it all. Thanks! – stragu Aug 9 '16 at 11:55
  • I had hunted around all over the place for an answer, too! You fixed it in 2 seconds! LEGEND! – Pepe Lebuntu Sep 30 '16 at 4:18
9

I got it fixed by doing following:

  1. open terminal and run alsamixer
  2. when you plugin your headphones, this should be the configuration:

    master - 00,  64(need not be 64, can be any other value)
    headphones - 00, 100
    speakers MM, 0    
    

In my case, headphones was showing MM instead of 00. It can be changed by moving to headphones and pressing m.

  • This did it for me as well, with a SoundBlaster Recon3Di. – Marcus Ottosson Jan 24 '16 at 14:44
  • Worked in thinkpad t460 too, ubuntu 16.04 – sudshekhar Aug 18 '16 at 10:00
2

I found this tip for Ubuntu 13.10 and it worked for me after I upgraded to 14.04.1, maybe it works for you as well? :)

"Probably, your Headphone Jack Sense is turned off..

Try this:

Open Terminal. Type in alsamixer. Locate and navigate to "Headphone". Press m. This should turn on your Headphone Jack Sense."

0

This problem seems to have fixed itself, an update that came out last week made my headphones work again.

  • Please consider marking it as accepted. – Parto Sep 17 '14 at 21:02

protected by Community Mar 15 '15 at 7:35

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.