1

I have a problem. I have a lapop with an Nvidia card and an Intel one

While I am using the Nvidia one (using PRIME profiles) I cannot change the display resolution using xrandr in terminal. All it does is that the display goes black for a second then back to the native resolution. However, when using the Intel card it works without an issue.

This is an issue for me because I play a lot of old games using Wine and most of them have very low resolutions and so, when using Nvidia, they are displayed on the top-left part of the screen, instead of being stretched to fill the whole screen like they do when using the Intel card (because the screen resolution will change to that of the game)

I also noticed that changing the resolution through System Settings -> Display works on both cards but it dosen't help much...

If I could get xrandr to change the resolution on the Nvidia card then those games will work or if not then I could make a script to do it when the game launches and change back to the native one when it's closed.

My OS is Ubuntu 14.04 x64 and I use the up-to-date Nvidia proprietary stable drivers. It's a laptop if that matters

EDIT: I just noticed that if I connect an external monitor (VGA1) I can change the resolution just fine on either monitor... and the game now runs fullscreen... but as soon as I disconnect it the issue comes back :(

  • xrandr does not work with the nvidia driver, you have to use nvidia-settings. – Panther Sep 1 '14 at 14:10
  • Ok. How can I change the resolution in terminal using nvidia-settings? – Horațiu Mlendea Sep 1 '14 at 14:14
  • You can't, you need a graphical interface. Why would you install the nvidia driver if you do not use a graphical interface? – Panther Sep 1 '14 at 14:27
  • I do use a graphical interface. I needed a terminal command in order to make a script that will change the resolution to that of the game and back when it's closed. – Horațiu Mlendea Sep 1 '14 at 14:29
  • I do not know how else to tell you the feature you want is not possible with the nvidia driver from the command line. As it is a closed source driver i suggest you file a bug report or feature request with nvidia. – Panther Sep 1 '14 at 14:41
0

I spent a lot of time with the same trouble, now I resolve it by using --crtc parameter when calling xrandr, i.e.:

xrandr --output LVDS1 --mode 800x600 --crtc 0

Also I reccomend to assign this commands to CCSM commands and bind to some hotkeys, it's very useful.

UPD: For me it's working only after this command:

xrandr -s 0

But this makes Diablo crashes on screen resolution change )-:

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.