3

I recently upgraded from 12.04 to 14.04 on my laptop and I am not able to print on a network printer via CUPS anymore. If I run

system-config-printer

I get the error

There was an error during the CUPS operation: 'Bad Request'.

If I run

system-config-printer --debug

I get the following output:

OpenPrinting: Init ('en_US', 'UTF-8') 1 0
+<NewPrinterGUI object at 0x7ff964028460 (newprinter+NewPrinterGUI at 0xea5ba0)>
Connected as user roberto
+<PrinterPropertiesDialog object at 0x7ff964041dc0   (printerproperties+PrinterPropertiesDialog at 0xf0b3a0)>
<authconn.Connection instance at 0x7ff964033830>: Operation += obtaining queue details
Authentication pass: 1
Authentication: password callback set
1024: u'Bad Request'

If I instead run the command with sudo I can access the dialog and set the printers, but then the applications that do not run as root cannot see the printers set by root.

The variable

CUPS_SERVER

is set and exported both by the .profile in my home directory and in /etc/profile.

I googled unsuccessfully so far. I also reinstalled cups after having removed it with --purge. Any hint?

  • What is the output of groups? – saiarcot895 Sep 1 '14 at 12:04
  • roberto adm lp dialout cdrom plugdev lpadmin admin sambashare – user626207 Sep 1 '14 at 12:05
  • roberto is the user I log in with – user626207 Sep 1 '14 at 12:06
  • Anyway since I upgraded from 12.04 to 14.04, and before the upgrade I had no problem when printing with my user, I tend to exclude the possibility of rights issue – user626207 Sep 2 '14 at 7:23
  • Other info: with firefox running normally (not as root) I can see the page localhost:631 and I can see all printers. However, the print dialog box doesn't show the same printer configured by root, and I can't run system-config-printer to set them! – user626207 Sep 2 '14 at 7:35
2

We had the same issue after updating from 12.04 to 14.04, same error dialog box but still able to see the printers via a browser, and a similar error message from system-config-printer --debug . Here was the solution that worked in our case:

In /etc/cups/cupsd.conf we replaced the default browsing section with:

# Show shared printers on the local network.
Browsing On
BrowseOrder allow,deny
# (Change '@LOCAL' to 'ALL' if using directed broadcasts from another
subnet.)
BrowseAllow @LOCAL
BrowsePoll printhost.yourserveraddress.com

And in /etc/cups/client.conf we added /version=1.1 to the server address:

ServerName printhost.yourserveraddress.com/version=1.1

After restarting cups with sudo service cups restart the network printers were visible and usable.

I hope you found a solution sooner than this, but I wanted to reply here as I found this question when I had this problem the other day, and hopefully it'll help anyone else updating to 14.04 a little late.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.