0

I am using an HP TouchSmart 600 that came from factory with Windows 7 Home Premium 64-bit. I have decided to get rid of it and installed Ubuntu 14.04 booting from USB and everything went perfect. Now, I want to install again Windows 7 so I downloaded the ISO image from the web and created a bootable USB using YUMI from pendrivelinux.com (my CD/DVD does not work and I don't have original windows CD) after reboot I keep getting this message "Missing Operating System", then Ubuntu is loaded normally.

I have been working to solving this for several days already and tried everything in the forums but nothing worked for me:

  1. I have downloaded many different ISO versions from the web to make sure the files were not corrupted.

  2. I have formatted the USB with gparted in NTFS and also in FAT32 before installing the ISO and I have also tried to boot in all possible usb slots to make sure I am using the primary one.

  3. I have updated the BIOS to boot from the USB device as a very first option.

PS: Please note I am not using any partition, I just want to install Windows 7 back in my machine and after that I will probably use dual-boot to keep using Ubuntu. I wanted to add how the USB looks like but when I run the tree command from terminal is a very long file so just for your reference this is what I can see in the root: I have 6 folders (boot, efi, sources, support, upgrade, yumi) and 4 files (autorun.inf, bootmgr, bootmgr.efi, setup.exe)

Please do let me know if you need any extra information from my side.

1

You can try with mkusb version 12. Install mkusb according to this link,

https://help.ubuntu.com/community/mkusb

If you run standard Ubuntu, you need an extra instruction to get the repository Universe. (Kubuntu, Lubuntu ... Xubuntu have the repository Universe activated automatically.)

sudo add-apt-repository universe  # only for standard Ubuntu

sudo add-apt-repository ppa:mkusb/ppa  # and press Enter
sudo apt-get update
sudo apt-get install mkusb mkusb-nox usb-pack-efi

See the detailed information at this link, describing how to create a drive to install Windows,

mkusb - Windows USB install drive

|improve this answer|||||
0

Have you updated the GRUB after Windows 7 installation? Grub menu can be updated or repaired or modified for dual-boot. See this page Grub update.

|improve this answer|||||
0

Try using WINUSB,very easy to use, i just used it to boot windows 7 ultimate x64 and it worked perfectly, since there is no package on the repos of Ubuntu 14.04 i give you this link with a tutorial of how install it that also contains the download links.

Installing WinUSB on Ubuntu 14.04

|improve this answer|||||
  • Add some description man! You should mention some important points about it when external links are suggested. – MANI Sep 1 '14 at 15:51
  • I have followed that wonderful tutorial and i realized i did 2 things wrong: 1)I did not place a boot flag in gparted. 2)I was using the most updated version of UNetbootin so i was not able to select the correct usb. I am re-sending the link (as the initial answer was edited) in case it can help somebody else: webupd8.org/2010/10/create-bootable-windows-7-usb-drive.html Thanks a lot z3ro, you really helped me out with this. Have a great day! – user3552392 Sep 2 '14 at 14:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.