0
$ sudo apt-get install libffi6 libffi-dev

Reading package lists... Done
Building dependency tree       
Reading state information... Done
libffi6 is already the newest version.
The following packages were automatically installed and are no longer required:
  gir1.2-dbusmenu-gtk-0.4 update-notifier-common gir1.2-gtk-2.0 language-pack-kde-en kde-l10n-engb language-pack-kde-en-base
Use 'apt-get autoremove' to remove them.
The following NEW packages will be installed:
  libffi-dev
0 upgraded, 1 newly installed, 0 to remove and 255 not upgraded.
Need to get 96.1 kB of archives.
After this operation, 356 kB of additional disk space will be used.
Do you want to continue [Y/n]? Y
Get:1 http://in.archive.ubuntu.com/ubuntu/ precise/main libffi-dev amd64 3.0.11~rc1-5 [96.1 kB]
Fetched 96.1 kB in 2s (40.9 kB/s)
Selecting previously unselected package libffi-dev.
(Reading database ... 221614 files and directories currently installed.)
Unpacking libffi-dev (from .../libffi-dev_3.0.11~rc1-5_amd64.deb) ...
Processing triggers for doc-base ...
Processing 1 added doc-base file...
Processing triggers for install-info ...
Processing triggers for man-db ...
Setting up libffi-dev (3.0.11~rc1-5) ...

and then,

:/opt/wunderlist-1.2.4/Wunderlist-1.2.4$ sudo ./Wunderlist   

./Wunderlist: error while loading shared libraries: libffi.so.5: cannot open shared object file: No such file or directory

More info:

$ cat /etc/issue
Ubuntu 12.04.4 LTS \n \l

What am I supposed to do now?

3

Wunderlist seems to specifically look for an older version of your libffi, it wants libffi5:

libffi.so.5: cannot open shared object file: No such file or directory

You're on 12.04 and the package libffi5 (3.0.9-1) is only available in the lucid repos.

You could add the lucid repos to your /etc/apt/sources.lst and manually install the older package from the lucid repos, creating a mixed system from 12.04 and 10.04. I'd consider this a bad idea, because manually adding very old stuff isn't necessarily leading to a stable system.

Or you could ask the programmer of wunderlist to update their dependencies, perhaps it also works with libffi6.

3rd possible solution, mentioned here (German) Just symlink 6 to 5:

ln -s /usr/lib/i386-linux-gnu/libffi.so.6 /usr/lib/i386-linux-gnu/libffi.so.5
  • Thanks. So, what's the solution now? – Aquarius_Girl Sep 1 '14 at 8:13
0

Use

https://packages.debian.org/wheezy/amd64/libffi5/download

to get latest version for your platform (link above is for amd64) and after installation you should get needed library in place

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.