When I enable a dual-screen with the NVidia X-Server Settings (TwinView) my laptop becomes very slow (you can't work anymore) after a short time. Strangely enough this occurred with Dell and Samsung monitors but it kept working fine with a LG monitor.

I searched google, but couldn't find any pointers yet (neither on askubuntu or bugs.launchpad.net), so I hope someone recognizes this or help me to report a good bugreport.

My graphics card info is

01:00.0 VGA compatible controller: nVidia Corporation G96M [Quadro FX 770M] (rev a1) (prog-if 00 [VGA controller])
    Subsystem: Hewlett-Packard Company Device 30e7
    Flags: bus master, fast devsel, latency 0, IRQ 16
    Memory at d2000000 (32-bit, non-prefetchable) [size=16M]
    Memory at c0000000 (64-bit, prefetchable) [size=256M]
    Memory at d0000000 (64-bit, non-prefetchable) [size=32M]
    I/O ports at 7000 [size=128]
    Expansion ROM at <unassigned> [disabled]
    Capabilities: <access denied>
    Kernel driver in use: nvidia
    Kernel modules: nvidia-current, nouveau, nvidiafb

I pasted my full hardware info at http://paste.ubuntu.com/638376/ Just tell me if you need to know more.

  • I updated my desktop at work. And I have a horrible fps. Every worked in 11.04 but after the update to 11.10 things goes really slow. Disabled lots of compiz features, but no cigarr. Tried a few different drivers but nope. I have the Quadro NVS 290 with two HP monitors. It looks now that I have to go back to 11.04, and I really like 11.10 on my other computers. Even my laptop is faster than this.. – Falk Oct 14 '11 at 15:27

I am encountering the exact same issue in 11.10 (Quadro NVS 290 on Dell monitors). I was able to make things a little bit more tolerable by using the driver version 173 instead of the recommended version.

This breaks nvidia-settings though, as it can't detect monitors correctly with the older driver. I installed the new driver, configured TwinView, then reverted to the old driver. The configuration kept working, and was a little speedier than compared to the defaults.


I had the same problem as this bug, so it can be interesting to follow it.. https://bugs.launchpad.net/ubuntu/+source/unity/+bug/874619

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.