0

I recently got a new(ish) computer, and I wanted to install Ubuntu on it (I use a [outdated] version on my main computer, so I figured it was no big deal.) I want to dualboot, so I opened up gparted as root and tried to resize the main partition (currently containing windows formatted in ntfs). It gave me this error:

and didn't let me touch the partition without getting mad at me. I have the required packages for mounting ntfs partitions that it says I'm missing, mounting the partition in nautilus and accessing it via /mount/whatever works fine, gparted is the only program to have this issue.

Is there a problem with my software, or is there an issue with the partition itself? I would have tried updating a few packages, but both wired and wireless internet were broken for some reason (never had this issue with 12.04). Thanks for any help you can provide.

0

There are several possibilities here. First off, is the current system bootable (Win. 7-8)?

-If so, you may need to boot into the current OS, then "Restart" into the Ubuntu install medium.

-If not, the volume may be locked (encrypted), try to mount the volume.

In the case you are able to mount the volume in RW "Read/Write" mode, try GParted again. If all of the above fail, boot into the current OS, and use this free tool to shrink the partition you wish to use, then install Ubuntu onto it.

[EDIT]: It appears you edited your question while I composed my answer, please ignore any duplicate information I may have provided.

5
  • It was mounted in RW mode, I should have specified it. I still tried restarting into the live disk, and had the same results. I know that the partition is not encrypted. – Mobo Sep 1 '14 at 17:48
  • @Mobo Are you able to boot into the current OS? – john kieran Sep 1 '14 at 17:54
  • Yes, no problems there – Mobo Sep 1 '14 at 23:56
  • When you boot into your current os (assuming Windows) use: easeus.com/partition-manager/epm-free.html to do your partitioning inside of Windows. – john kieran Sep 2 '14 at 1:15
  • 1
    This problem can happen when Windows is not shut down properly and leaves the NTFS file system in an inconsistent state. If this is the case then boot into Windows and properly shutdown using "Start -> Shutdown". Then boot the live disk and try running gparted again. – Curtis Gedak Sep 4 '14 at 16:46
0

I had the same problem with NTFS in GParted to install Ubuntu 14.04.2 (told me to install NTFS-3G that was already installed) and I follow the simple solution of Curtis Gedak: shutdown Ubuntu, boot into Windows, shut it down normally and boot into Ubuntu again. And it worked perfectly for me.

1
  • when you convert someone else's comment to an answer, 1/ ask the original poster if he/she/it wishes to answer him/here/itself. 2/ click the "community wiki" link before posting the answer if you get no response. Thank you!!! – Fabby Jul 12 '15 at 0:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.