1

I just updated to 14.04 from 12.04 and graphics performance was a bit choppy/sluggish (AMD/ATI Mobility Radeon 4xxx). There's so much information and advice about what to do in this situation that I felt lost, so I just decided to go ahead and try installing the fglrx drivers.

I did this from the software center and now every time I boot there's no display. The only thing I can use to interact with the system is the root shell prompt in recovery mode. Can anyone tell me how to roll back or uninstall those fglrx drivers?

Running sudo apt-get remove fglrx results in:

Unable to write to /var/cache/apt
The package lists or status files could not be opened

  • possible duplicate of "The package lists or status file could not be parsed or opened" – przemo Aug 31 '14 at 19:19
  • Are you saying that if I can fix the remove fglrx command then that is the appropriate thing to do in this case? – RTF Aug 31 '14 at 19:26
  • No, I'm suggesting that The package lists or status files could not be opened is a problem with apt, not with fglrx and it's a problem that was already solved. In your case I would remove it completely using apt-get purge fglrx* and remove Xorg.conf. Linux kernel has open source drivers that will work with your card. Then if every thing works fine, you can install new proprietary drivers if you really need them. – przemo Aug 31 '14 at 19:34
4

I found this link which solved the problem for me. In summary:

Since Natty (11.04), Ubuntu will mount your root partition as read only, so you can’t make any change right away... To get Read Write, you need to run this in root shell:

mount -o remount,rw /

apt-get commands worked for me after that. I ran apt-get remove fglrx* and after rebooting the open-source drivers are being used.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.