1

I am not able to download and install programs (including vlc and unity tweak tool) from the Ubuntu Software Center. Every time i try to get them, there is a dependency error and i am completely lost now.

I am using Ubuntu 14.04 (64bit).

More Details:

**Package dependencies cannot be resolved**
This error could be caused by required additional software packages which are missing or not installable. Furthermore there could be a conflict between software packages which are not allowed to be installed at the same time.

The following packages have unmet dependencies:

vlc: Depends: vlc-nox (= 2.1.4-0ubuntu14.04.1) but 2.1.4-0ubuntu14.04.1 is to be installed
     Depends: libc6 (>= 2.15) but 2.19-0ubuntu6.3 is to be installed
     Depends: libfreetype6 (>= 2.2.1) but 2.5.2-1ubuntu2 is to be installed
     Depends: libgcc1 (>= 1:4.1.1) but 1:4.9-20140406-0ubuntu1 is to be installed
     Depends: libqtcore4 (>= 4:4.8.0) but 4:4.8.5+git192-g085f851+dfsg-2ubuntu4 is to be installed
     Depends: libqtgui4 (>= 4:4.8.0) but 4:4.8.5+git192-g085f851+dfsg-2ubuntu4 is to be installed
     Depends: libsdl-image1.2 (>= 1.2.10) but it is not going to be installed
     Depends: libsdl1.2debian (>= 1.2.11) but it is not going to be installed
     Depends: libstdc++6 (>= 4.6) but 4.8.2-19ubuntu1 is to be installed
     Depends: libtar0 but it is not going to be installed
     Depends: libva-x11-1 (> 1.3.0~) but it is not going to be installed
     Depends: libva1 (> 1.3.0~) but it is not going to be installed
     Depends: libxcb-composite0 but it is not going to be installed
     Depends: libxcb-keysyms1 (>= 0.3.9) but it is not going to be installed
     Depends: libxcb-xv0 (>= 1.2) but it is not going to be installed
     Depends: zlib1g (>= 1:1.2.3.3) but 1:1.2.8.dfsg-1ubuntu1 is to be installed

Results of commands requested:

sudo apt-get update & sudo apt-get upgrade & sudo apt-get install -f

result: http://imgur.com/Qm4MpBD,6iEK7Ii,u3fKB8J,PxMu2fD,jSlxc7g

sudo apt-get update && sudo dpkg-reconfigure -a && sudo apt-get -f install -y

result: http://imgur.com/aR0tqOR,scFa41p,GaVTXnJ,VUescrg,gtl4HDQ

  • Can you append your question to add the output of the commands sudo apt-get update and sudo apt-get upgrade – Charles Green Aug 31 '14 at 13:37
  • Need more info, try sudo apt-get update && sudo dpkg-reconfigure -a && sudo apt-get -f install -y. – przemo Aug 31 '14 at 13:37
  • Have you ever installed any software using a downloaded .deb file that wasn't from the default Ubuntu repositories? – JohnP Aug 31 '14 at 14:25
  • I don't think so. Have updated the Question to provide further clarification. Moreover, this problem persists since the first day of installing 14.04 version. – a1ighalib Aug 31 '14 at 17:49
  • Have updated the output of commands in the question to provide more info. Looking forward for insights of both of you. – a1ighalib Aug 31 '14 at 22:06
2

Open System Settings -> Software and Updates -> Ubuntu Software tab -> Download from -> Other -> Select best server -> choose the best server
and update your system once you have selected the best server

1

In the Ubuntu Update menu, by changing the mirror from non-US to US, I was able to download all the required packages and the problem of dependencies is resolved.

Moreover, Now I am able to install any software from the Ubuntu Software Center.

1

I had the same problem. I plugged my laptop into a wired internet connection and updated the software repositories. This solved the problem for me.

0

To get all missing dependencies open a terminal and execute the following commands:

sudo apt-get update

sudo apt-get install -f
  • Didn't resolve the problem. Have updated the results of commands in the question , kindly can you review it again. – a1ighalib Aug 31 '14 at 22:00
  • Didn't resolve the issue for me either. Same system, same problem. – Matt O'Brien Nov 22 '14 at 23:29
0

Search software and update.Go to Update software menu.In download from option select appropriate server from list. Like I am from India and I selected other >> India >> ftp.iitb.ac.in (server in IIT-Bombay). This worked for me and I am able to install any software.

In case it doesn't work let me know so that I can suggest you other required settings for software and update.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.