0

In Lubuntu 13.10 I was able to redirect the kernel messages/logging to another tty by adding the following to the Grub file in order to hide all kernel boot messages when disabling the splash screen and it booted very quickly:

GRUB_CMDLINE_LINUX="console=tty12"

However when I add the same line to Grub in Lubuntu 14.04.1 I still get all of the boot/logging messages, which actually is taking much longer to boot than having the splash screen present.

Is there a way to hide all the boot messages applicable to Lubuntu 14.04.1, as it appears redirecting the kernel messages to another tty isn't working.

Any assistance would be greatly appreciated. Thank you!


Edit (regarding marus' answer): Yes, after I added the new parameter and deleted "splash" I did run sudo update-grub and the new parameter was present after updating and also after re-booting and splash was not present.

Yes I did delete "splash" and kept "quiet".

I still receive a whole screen worth of boot/logging messages. I also tried console=tty6 and console=tty9 and neither worked. I still receive boot messages.

The only way to not receive boot messages is to re-add "splash".

  • Is this problem solved? Even I'm working on it. And I changed the configuration by removing splash and keeping quiet and I got a kernel panic :-| – Thushi Feb 25 '15 at 6:12
  • Unfortunately I gave up trying to resolve the situation. There probably is a solution I just haven't found one as of yet. So I have kept the spash screen as is. – user236378 Feb 26 '15 at 23:46
  • I am having problem while switching to X after boot animation completes. I am getting some boot logs before switching to X. It is like....Boot animation completes and I ll get some boot logs and then it will switch to X :( – Thushi Feb 27 '15 at 9:49
0

If you don't need to see the messages in the TTY, then you can set the quiet parameter instead. By default, you have quiet splash, just delete the splash.

  • Yes I did keep the "quiet" parameter. I still receive a whole screen of boot messages. The only way to not get the messages is to re-add the "splash" parameter. – user236378 Sep 2 '14 at 0:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.