11

Remmina 0.9.99.1, Ubuntu 14.04.

I installed Remmina from the repository. Also installed both the RDP and the VNC plugins from the repository. I have verified that remmina-plugin-vnc.so is in /usr/lib/remmina/plugins/

When I start Remmina, I see only the plugins for RDP, nothing for VNC.

Connecting to a remote host using RDP works just fine. Of course, if I try to connect to a remote host that requires the VNC protocol, I cannot, Remmina won't work in that case.

I've tried all kinds of solutions, but nothing's worked so far. I've tried complete removal and reinstallation, restarting Remmina, restarting the computer, etc.

(I originally asked this question on the "issues" GitHub page for Remmina, but they closed the question and told me that they wouldn't address it, that I had to ask it here.)

Please help me with this problem. Thanks.

11

In case others come across this post. Remmina used to come with RDP and VNC options, now they are plugins.

After you install the plugins it's not enough to just close and reopen remmina. I think something gets left open, so you may need to kill a task or simply reboot.

ps -A | grep remmina
  4853 ?        00:01:15 remmina
kill 4853   #the process ID from above

So here's how to get everything going:

#to install remmina
sudo apt-get install remmina

# get the other mode plugins
sudo apt-get install remmina-plugin-vnc
sudo apt-get install remmina-plugin-rdp

# probably not needed
sudo apt-get install freerdp
sudo apt-get install libjpeg-dev

FYI: the plugins install to /usr/lib/remmina/plugins

6

you can find the bug's report here and the user Raony Guimarães gave next solution:

sudo apt-get install libvncclient0
sudo remmina

for some reason I still need to use sudo in order to use vnc with remmina

It works for me, and after do that, I can start remmina without sudo and connect a remote pc through vnc protocol without any issue.

Be warned, however:

If you started remmina with sudo, then remmina creates config files with root ownership. You can chown permissions back from root to your user, then use without sudo.

1
  • 1
    With me it worked without sudo, but i had to kill the process using killall remmina – Salem Mar 24 '15 at 21:48
4

Fixed by reinstalling:

sudo apt-get purge libvncserver0

and then

sudo apt-get install remmina-plugin-vnc

source

1

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.