0

I'm on Ubuntu 14.04, on a Lenovo y410p Ideapad, and I'm having an issue where my mouse movements are registering as a tap even when I've actually moved my cursor. For instance, maybe I have the cursor 100 pixels away from something and I move the cursor quickly to the target. When I lift my finger, Ubuntu thinks I've clicked.

I'm guessing there's a time thresh hold for how long the touchpad can be engaged, and if the movement is less than that amount of time it registers as a click? If so, I'd like to shorten this thresh hold. But maybe it doesn't work like that?

It's really annoying, since any small movement of the mouse usually results in a click, often closing tabs or windows unintentionally.

2
  • What about decreasing the pointer speed? It's under the Mouse & Touchpad section of the settings. omgubuntu.co.uk/wp-content/uploads/2013/02/…
    – tlng5
    Commented Aug 30, 2014 at 22:17
  • Thanks, but I don't think that solves the issue. Yeah it would make me have to spend more time moving the cursor but the problem would still be there in principal.
    – Josh Lemer
    Commented Aug 30, 2014 at 22:41

1 Answer 1

0

Maybe this also helps here:

Edit the file

/usr/share/X11/xorg.conf.d/50-synaptics.conf 

And edit the "touchpad catchall" section, so it will look like this:

Section "InputClass"
Identifier "touchpad catchall"
Driver "synaptics"
MatchIsTouchpad "on"
# This option is recommend on all Linux systems using evdev, but cannot be
# enabled by default. See the following link for details:
# http://who-t.blogspot.com/2010/11/how-to-ignore-configuration-errors.html
MatchDevicePath "/dev/input/event*"

Option "FingerLow"              "46"
Option "FingerHigh"             "46"
Option "ClickFinger1"           "1"
Option "ClickFinger2"           "2"
Option "ClickFinger3"           "3"
Option "TapButton1"             "1"
Option "TapButton2"             "2"
Option "TapButton3"             "3"
Option "AreaBottomEdge"         "85%"
Option "SoftButtonAreas"        "60% 0 85% 0 40% 60% 85% 0" # Btn2 LRTB - Btn3 LRTB
Option "EmulateMidButtonTime"   "75"
EndSection

(source: http://memobadz.wordpress.com/2014/02/16/lenovo-yoga-pro-2-on-ubuntu/ )

Try some of the tips from here:

Ubuntu on Lenovo Yoga 2 Pro

3
  • Hmm, the comments at the top of the file warn against editing the file, are you sure it's a good idea? >DO NOT EDIT THIS FILE, your distribution will likely overwrite it when updating. Copy (and rename) this file into /etc/X11/xorg.conf.d first.
    – Josh Lemer
    Commented Aug 30, 2014 at 22:37
  • You should try it, I used it for nearly a year now without problems with my Touchpad. And if the distribution changes it again, you know where to find the settings (here)
    – rubo77
    Commented Aug 30, 2014 at 22:49
  • Yes, try it and if it doesn't help, you can fiddle around with synclient to find the right settings
    – rubo77
    Commented Aug 30, 2014 at 22:54

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .