8

After an upgrade from version 36 to 37, the fonts in Google Chrome browser and its opensource variation Chromium look much worse. In the attached screenshot you will the same page viewed with version 37 (left) and 36 (right). The fonts on the left are visible fatter and fuzzier than in Chromium. Any way to fix it?

Screenshot: fonts rendering comparison, Google Chrome (left) and Chromium (right)

UPDATE: I googled and found that starting with version 37 Google Chrome comes with a feature DirectWrite with is meant to improve font rendering for Windows users. It seems the font looks in Linux is also affected by this. However, on Linux there seems to be no way to disable this feature using chrome://flags. For now, I downgraded my browsers to a version prior to 37.

1

Ok, I am now able to use the newest version of Google Chrome without being annoyed at the fonts. I improved the fonts' visibility buy setting the hinting style to full:

  1. Go to System Settings > Application Appearance > Fonts
  2. Configure anti-aliasing
  3. Set hinting to full.
  4. Close the window and reopen them again or log out and in again to see the change across the system.
  • If this answer has helped you solve your problem then why didn't you mark it as "accepted"? – usmanayubsh Jan 22 '16 at 20:22
0

please test if by overriding the system settings for Microsoft type fonts the problem is solved. The problem is because freetype, the font rendering engine works differently trying to render Windows type fonts correctly (This is more of a horrible job in Microsoft than on Linux) by taking into account the embedded bitmaps these fonts have inside by default. So do the following:

  1. Create the folder ~/config/fontconfig if it does not exist and then go inside of it.

  2. Create the file fonts.conf inside of it with the following information:

<match target="font" >
    <edit name="embeddedbitmap" mode="assign">
        <bool>false</bool>
    </edit>
</match>
  1. Save and logout of you session and back in. Test to see if you can now see the webpages correctly, emails and such. This also helps other rending apps like LibreOffice, Inkscape and more.
  • Thank you for your answer. I tested it. Unfortunately, there was no effect on Chrome/Chromium version 37. I think it's something specific to the browser I also have version 36 installed where the fonts look much better either with embeddedbitmap enabled or disabled. – datka Sep 13 '14 at 19:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.