2

After restarting my laptop the Alternative Characters Key doesn't work. Although it is set as Right Alt I can't enter Polish characters such as "ł,ó,ą,ę,ż,ź,ć,ń" using it. I always have to go to System Settings -> Keyboard -> Shortcuts -> Typing and there I just have to change any one of the shortcuts to something else (for example 'disabled') for a moment and then set it again to the previous value. This is really unexpected but after this typing works fine, however it drives me mad that I have to do it every time I start my laptop!

The problem may have started when I installed Wine and a game 'Heroes of Might and Magic III' but I'm not sure. It may as well have begun when I installed some other programmes for Ubuntu such as audio-recorder or lmms. I have tried removing all the recently installed programs including wine but nothing solved the problem. Please, help!

  • I had similar issue with Chinese. I had to install it through Language Support in settings – Sergiy Kolodyazhnyy Aug 30 '14 at 12:59
  • Unfortunately, in my case changing system language to Polish in Language Support doesn't help. – geras Sep 3 '14 at 12:02
  • @geras did you find out where was a problem? I have very this same problem :( – noisy Nov 27 '14 at 20:55
  • For anyone reading this - noisy found the solution which is below. – geras Dec 1 '14 at 22:08
1

Here I found solution, which works for me.

Type in console ibus-setup, and then make sure, that you have following settings: enter image description here enter image description here enter image description here

To avoid different problems with switching beetwen Polish and English, I removed English from list.

enter image description here

Proof: u mnie działa świetnie :)

  • Thanks, you're great! It turned out what I needed to do was just to remove English from this list. (no need to change to Dvorak layout) – geras Dec 1 '14 at 22:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.