Yesterday, I updated all packages through the software updater. It installed kernel 3.13.0-35. When I rebooted, I would get a completely unresponsive blank screen, so I went back to the Grub menu and I booted into the previous kernel: 3.13.0-34. Basically, 35 just wouldn't work and 34 would.

Then I uninstalled the latest kernel like so:

sudo apt-get remove 3.13.0-35

Now my question is two-fold:

  1. The Software Updater does not show me any kernel updates now. Is this normal?
  2. How can I be informed of kernel updates again (through the software updater)?

I feel that uninstalling 3.13.0-35 has somehow disabled kernel updates completely.

Output of sudo update-grub:

Generating grub configuration file ...
Found linux image: /boot/vmlinuz-3.13.0-34-generic
Found initrd image: /boot/initrd.img-3.13.0-34-generic
Found linux image: /boot/vmlinuz-3.13.0-33-generic
Found initrd image: /boot/initrd.img-3.13.0-33-generic
Found linux image: /boot/vmlinuz-3.13.0-32-generic
Found initrd image: /boot/initrd.img-3.13.0-32-generic
Found memtest86+ image: /boot/memtest86+.elf
Found memtest86+ image: /boot/memtest86+.bin
Found Windows 8 (loader) on /dev/sda1
  • Did you really remove that kernel with this sudo apt-get remove 3.13.0-35??? I don't think so. output of sudo update-grub please. Aug 30, 2014 at 11:32
  • Updated post with grub info. And yes, that's the command I used, you can try it yourself.
    – Mendhak
    Aug 30, 2014 at 11:47

1 Answer 1


The metapackages that depend on the actual kernel packages got removed when you removed the actual packages. These metapackages are used to signal availability of new kernel versions. For the moment, install old versions:

sudo apt-get install linux-generic=<old-version>

You can find out the old version available using apt-cache policy linux-generic.

A sample output of the policy looks like:

$ apt-cache policy linux-generic
  Version table:
 *** 0
        500 http://mirror.cse.iitk.ac.in/ubuntu/ trusty-updates/main amd64 Packages        500 http://mirror.cse.iitk.ac.in/ubuntu/ trusty-security/main amd64 Packages
        100 /var/lib/dpkg/status 0
        500 http://mirror.cse.iitk.ac.in/ubuntu/ trusty/main amd64 Packages

From the version table, I have and available, and the former is installed. So to get the metapackage for the older version, I can do:

sudo apt-get install linux-generic=
  • What would I put in place of <old-version>? I tried sudo apt-get install linux-image-generic=3.13.0-34 but I get E: Version ‘3.13.0-34’ for ‘linux-image-generic’ was not found
    – Mendhak
    Aug 30, 2014 at 11:49
  • @Mendhak Did you run the apt-cache command I gave?
    – muru
    Aug 30, 2014 at 11:50
  • @Mendhak You are already installed version 3.13.0-34. Which version of kernel do you want to install? Aug 30, 2014 at 11:51
  • Ah sorry that was it. I got from your command, so I ran sudo apt-get install linux-image-generic= and now I am getting updates again. Appreciated!
    – Mendhak
    Aug 30, 2014 at 11:52
  • 1
    @Mendhak There's a more general metapackage available called linux-generic. Install that too. I'll update the answer.
    – muru
    Aug 30, 2014 at 11:54

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .