0

This question already has an answer here:

I have spent hours trying to upgrade, reading the forum, trying solutions but unable to get really anywhere. It is my sons computer and all he does on it is play minecraft. Please help and sorry if this is a duplicate.

Can't Calculate Upgrade

Error pkg ProblemResolver; resolve generated breaks, this may be causes by installed held packages. Usually means that your installed packages have unmet dependencies

Synaptic finds no broken packages to fix

Here is some data :

Log File

2014-08-30 07:13:50,756 INFO fixing components inconsistency from 'deb http://archive.ubuntu.com/ubuntu trusty-updates universe'
2014-08-30 07:13:50,756 INFO to new entry 'deb http://archive.ubuntu.com/ubuntu trusty-updates universe main restricted multiverse'
2014-08-30 07:13:52,913 DEBUG running doUpdate() (showErrors=True)
2014-08-30 07:14:08,771 DEBUG openCache()
2014-08-30 07:14:08,772 DEBUG failed to SystemUnLock() (E:Not locked) 
2014-08-30 07:14:13,192 DEBUG /openCache(), new cache size 45280
2014-08-30 07:14:13,193 DEBUG need_server_mode(): run in 'desktop' mode, (because of key deps for 'ubuntu-desktop')
2014-08-30 07:14:19,273 ERROR Dist-upgrade failed: 'E:Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.'
2014-08-30 07:14:19,274 DEBUG abort called
2014-08-30 07:14:19,277 DEBUG openCache()
2014-08-30 07:14:23,519 DEBUG /openCache(), new cache size 43154
2014-08-30 07:14:23,519 DEBUG enabling apt cron job

Sudo apt-get -f install
ylan@dylan-GJ417AA-UUZ-m8140-ch:~$ sudo apt-get -f install
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages were automatically installed and are no longer required:
  appmenu-qt5 libdbusmenu-qt5 libhud-client2 libpocketsphinx1 libsphinxbase1
  libunity-gtk2-parser0 libunity-gtk3-parser0 sphinx-voxforge-hmm-en
  sphinx-voxforge-lm-en unity-gtk-module-common unity-gtk2-module
  unity-gtk3-module
Use 'apt-get autoremove' to remove them.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
dylan@dylan-GJ417AA-UUZ-m8140-ch:~$ 

Auto Remove

The following packages will be REMOVED:
  appmenu-qt5 libdbusmenu-qt5 libhud-client2 libpocketsphinx1 libsphinxbase1
  libunity-gtk2-parser0 libunity-gtk3-parser0 sphinx-voxforge-hmm-en
  sphinx-voxforge-lm-en unity-gtk-module-common unity-gtk2-module
  unity-gtk3-module
0 upgraded, 0 newly installed, 12 to remove and 0 not upgraded.
After this operation, 35.8 MB disk space will be freed.
Do you want to continue [Y/n]? y
(Reading database ... 212158 files and directories currently installed.)
Removing appmenu-qt5 ...
Removing libdbusmenu-qt5:i386 ...
Removing libhud-client2:i386 ...
Removing libpocketsphinx1 ...
Removing libsphinxbase1 ...
Removing unity-gtk2-module ...
Removing libunity-gtk2-parser0 ...
Removing unity-gtk3-module ...
Removing libunity-gtk3-parser0 ...
Removing sphinx-voxforge-hmm-en ...
Removing sphinx-voxforge-lm-en ...
Removing unity-gtk-module-common ...
Processing triggers for libc-bin ...
dylan@dylan-GJ417AA-UUZ-m8140-ch:~$ 

Broken packages Gedit

Broken libqt5svg5:i386 Depends on libqt5gui5 [ i386 ] < 5.0.2+dfsg1-7ubuntu11.1 -> 5.2.1+dfsg-1ubuntu14.2 > ( libs ) (>= 5.0.2)
Broken qtdeclarative5-ubuntu-ui-toolkit-plugin:i386 Depends on libqt5svg5 [ i386 ] < none -> 5.2.1-1 > ( libs )
Broken libqt5printsupport5:i386 Depends on libqt5gui5 [ i386 ] < 5.0.2+dfsg1-7ubuntu11.1 -> 5.2.1+dfsg-1ubuntu14.2 > ( libs ) (>= 5.0.2)
Broken libqt5printsupport5:i386 Depends on libqt5gui5-gles [ i386 ] < none > ( none ) (>= 5.0.2)
Broken libqt5printsupport5:i386 Depends on libqt5widgets5 [ i386 ] < 5.0.2+dfsg1-7ubuntu11.1 -> 5.2.1+dfsg-1ubuntu14.2 > ( libs ) (>= 5.2.0)
Broken hud:i386 Depends on libqt5gui5 [ i386 ] < 5.0.2+dfsg1-7ubuntu11.1 -> 5.2.1+dfsg-1ubuntu14.2 > ( libs ) (>= 5.0.2)
Broken hud:i386 Depends on libqt5gui5-gles [ i386 ] < none > ( none ) (>= 5.0.2)
Broken hud:i386 Depends on libqt5widgets5 [ i386 ] < 5.0.2+dfsg1-7ubuntu11.1 -> 5.2.1+dfsg-1ubuntu14.2 > ( libs ) (>= 5.0.2)
Broken libqt5webkit5-qmlwebkitplugin:i386 Depends on libqt5quick5 [ i386 ] < 5.0.2-6ubuntu4 -> 5.2.1-3ubuntu15.1 > ( libs ) (>= 5.2.0)
Broken webapp-container:i386 Depends on libqt5gui5 [ i386 ] < 5.0.2+dfsg1-7ubuntu11.1 -> 5.2.1+dfsg-1ubuntu14.2 > ( libs ) (>= 5.0.2)
Broken webapp-container:i386 Depends on libqt5gui5-gles [ i386 ] < none > ( none ) (>= 5.0.2)
Broken webapp-container:i386 Depends on libqt5quick5 [ i386 ] < 5.0.2-6ubuntu4 -> 5.2.1-3ubuntu15.1 > ( libs ) (>= 5.2.0~rc1)
Broken webapp-container:i386 Depends on libqt5quick5-gles [ i386 ] < none > ( none ) (>= 5.2.0~rc1)
Broken webapp-container:i386 Depends on libqt5widgets5 [ i386 ] < 5.0.2+dfsg1-7ubuntu11.1 -> 5.2.1+dfsg-1ubuntu14.2 > ( libs ) (>= 5.0.2)
Broken liboxideqt-qmlplugin:i386 Depends on libqt5gui5 [ i386 ] < 5.0.2+dfsg1-7ubuntu11.1 -> 5.2.1+dfsg-1ubuntu14.2 > ( libs ) (>= 5.0.2)
Broken liboxideqt-qmlplugin:i386 Depends on libqt5gui5-gles [ i386 ] < none > ( none ) (>= 5.0.2)
Broken liboxideqt-qmlplugin:i386 Depends on libqt5quick5 [ i386 ] < 5.0.2-6ubuntu4 -> 5.2.1-3ubuntu15.1 > ( libs ) (>= 5.2.0~rc1)
Broken liboxideqt-qmlplugin:i386 Depends on libqt5quick5-gles [ i386 ] < none > ( none ) (>= 5.2.0~rc1)
Broken libunity-core-6.0-9:i386 Conflicts on libunity-core-6.0-8 [ i386 ] < 7.1.2+13.10.20131014.1-0ubuntu1 > ( libs )
Broken libunity-core-6.0-9:i386 Conflicts on unity-common [ i386 ] < none | 6.12.0-0ubuntu0.2 > ( gnome )
Broken libqt53d5:i386 Depends on libqt5gui5 [ i386 ] < 5.0.2+dfsg1-7ubuntu11.1 -> 5.2.1+dfsg-1ubuntu14.2 > ( libs ) (>= 5.0.2)
Broken libqt53d5:i386 Depends on libqt5gui5-gles [ i386 ] < none > ( none ) (>= 5.0.2)
Broken libqt53d5:i386 Depends on libqt5opengl5 [ i386 ] < 5.0.2+dfsg1-7ubuntu11.1 -> 5.2.1+dfsg-1ubuntu14.2 > ( libs ) (>= 5.0.2)
Broken libqt53d5:i386 Depends on libqt5opengl5-gles [ i386 ] < none > ( none ) (>= 5.0.2)
Broken libqt53d5:i386 Depends on libqt5quick5 [ i386 ] < 5.0.2-6ubuntu4 -> 5.2.1-3ubuntu15.1 > ( libs ) (>= 5.2.0)
Broken libqt53d5:i386 Depends on libqt5quick5-gles [ i386 ] < none > ( none ) (>= 5.2.0)
Broken libqt53d5:i386 Depends on libqt5widgets5 [ i386 ] < 5.0.2+dfsg1-7ubuntu11.1 -> 5.2.1+dfsg-1ubuntu14.2 > ( libs ) (>= 5.0.2)
Broken qtdeclarative5-accounts-plugin:i386 Depends on qtdeclarative5-qtquick2-plugin [ i386 ] < none -> 5.2.1-3ubuntu15.1 > ( libs )
Broken unity-webapps-qml:i386 Depends on libqt5webkit5-qmlwebkitplugin [ i386 ] < none -> 5.1.1-1ubuntu8 > ( libs )
Broken checkbox-gui:i386 Depends on qtdeclarative5-qtquick2-plugin [ i386 ] < none -> 5.2.1-3ubuntu15.1 > ( libs )
Broken qtdeclarative5-dialogs-plugin:i386 Depends on libqt5gui5 [ i386 ] < 5.0.2+dfsg1-7ubuntu11.1 -> 5.2.1+dfsg-1ubuntu14.2 > ( libs ) (>= 5.2.0)
Broken qtdeclarative5-dialogs-plugin:i386 Depends on libqt5gui5-gles [ i386 ] < none > ( none ) (>= 5.2.0)
Broken qtdeclarative5-dialogs-plugin:i386 Depends on libqt5quick5 [ i386 ] < 5.0.2-6ubuntu4 -> 5.2.1-3ubuntu15.1 > ( libs ) (>= 5.2.0)
Broken qtdeclarative5-dialogs-plugin:i386 Depends on libqt5quick5-gles [ i386 ] < none > ( none ) (>= 5.2.0)
Broken qtdeclarative5-ubuntu-ui-extras-browser-plugin:i386 Depends on libqt5gui5 [ i386 ] < 5.0.2+dfsg1-7ubuntu11.1 -> 5.2.1+dfsg-1ubuntu14.2 > ( libs ) (>= 5.0.2)
Broken qtdeclarative5-ubuntu-ui-extras-browser-plugin:i386 Depends on libqt5gui5-gles [ i386 ] < none > ( none ) (>= 5.0.2)
Broken qtdeclarative5-ubuntu-ui-extras-browser-plugin:i386 Depends on libqt5webkit5-qmlwebkitplugin [ i386 ] < none -> 5.1.1-1ubuntu8 > ( libs )
Broken libqt5location5:i386 Depends on libqt53d5 [ i386 ] < 5.0~git20130731-0ubuntu1 -> 5.0~git20130731-0ubuntu5 > ( libs ) (>= 5.0~git20130731)
Broken libqt5location5:i386 Depends on libqt53d5-gles [ i386 ] < none > ( none ) (>= 5.0~git20130731)
Broken libqt5location5:i386 Depends on libqt5gui5 [ i386 ] < 5.0.2+dfsg1-7ubuntu11.1 -> 5.2.1+dfsg-1ubuntu14.2 > ( libs ) (>= 5.0.2)
Broken libqt5location5:i386 Depends on libqt5gui5-gles [ i386 ] < none > ( none ) (>= 5.0.2)
Broken libqt5location5:i386 Depends on libqt5opengl5 [ i386 ] < 5.0.2+dfsg1-7ubuntu11.1 -> 5.2.1+dfsg-1ubuntu14.2 > ( libs ) (>= 5.0.2)
Broken libqt5location5:i386 Depends on libqt5opengl5-gles [ i386 ] < none > ( none ) (>= 5.0.2)
Broken libqt5location5:i386 Depends on libqt5widgets5 [ i386 ] < 5.0.2+dfsg1-7ubuntu11.1 -> 5.2.1+dfsg-1ubuntu14.2 > ( libs ) (>= 5.0.2)
Broken webbrowser-app:i386 Depends on libqt5gui5 [ i386 ] < 5.0.2+dfsg1-7ubuntu11.1 -> 5.2.1+dfsg-1ubuntu14.2 > ( libs ) (>= 5.0.2)
Broken webbrowser-app:i386 Depends on libqt5gui5-gles [ i386 ] < none > ( none ) (>= 5.0.2)
Broken webbrowser-app:i386 Depends on libqt5quick5 [ i386 ] < 5.0.2-6ubuntu4 -> 5.2.1-3ubuntu15.1 > ( libs ) (>= 5.2.0~rc1)
Broken webbrowser-app:i386 Depends on libqt5quick5-gles [ i386 ] < none > ( none ) (>= 5.2.0~rc1)
Broken webbrowser-app:i386 Depends on libqt5widgets5 [ i386 ] < 5.0.2+dfsg1-7ubuntu11.1 -> 5.2.1+dfsg-1ubuntu14.2 > ( libs ) (>= 5.0.2)
Broken qtdeclarative5-privatewidgets-plugin:i386 Depends on libqt5gui5 [ i386 ] < 5.0.2+dfsg1-7ubuntu11.1 -> 5.2.1+dfsg-1ubuntu14.2 > ( libs ) (>= 5.2.0)
Broken qtdeclarative5-privatewidgets-plugin:i386 Depends on libqt5gui5-gles [ i386 ] < none > ( none ) (>= 5.2.0)
Broken qtdeclarative5-privatewidgets-plugin:i386 Depends on libqt5quick5 [ i386 ] < 5.0.2-6ubuntu4 -> 5.2.1-3ubuntu15.1 > ( libs ) (>= 5.2.0)
Broken qtdeclarative5-privatewidgets-plugin:i386 Depends on libqt5quick5-gles [ i386 ] < none > ( none ) (>= 5.2.0)
Broken qtdeclarative5-privatewidgets-plugin:i386 Depends on libqt5widgets5 [ i386 ] < 5.0.2+dfsg1-7ubuntu11.1 -> 5.2.1+dfsg-1ubuntu14.2 > ( libs ) (>= 5.2.0)
Broken liboxideqtcore0:i386 Depends on libqt5gui5 [ i386 ] < 5.0.2+dfsg1-7ubuntu11.1 -> 5.2.1+dfsg-1ubuntu14.2 > ( libs ) (>= 5.0.2)
Broken liboxideqtcore0:i386 Depends on libqt5gui5-gles [ i386 ] < none > ( none ) (>= 5.0.2)
Broken appmenu-qt5:i386 Depends on libqt5gui5 [ i386 ] < 5.0.2+dfsg1-7ubuntu11.1 -> 5.2.1+dfsg-1ubuntu14.2 > ( libs ) (>= 5.2.0)
Broken appmenu-qt5:i386 Depends on libqt5gui5-gles [ i386 ] < none > ( none ) (>= 5.2.0)
Broken appmenu-qt5:i386 Depends on libqt5widgets5 [ i386 ] < 5.0.2+dfsg1-7ubuntu11.1 -> 5.2.1+dfsg-1ubuntu14.2 > ( libs ) (>= 5.0.2)

list of broken goes on and on....

marked as duplicate by Registered User, Eric Carvalho, Tim, Kaz Wolfe, Alaa Ali Sep 2 '14 at 16:16

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

0

I suggest you try to solve unmet dependencies first according to this answer How do I resolve unmet dependencies after adding a PPA?

And then remove unnecessary PPA and other archives in /etc/apt/sources.list file.

When you get this done then you can upgrade to 14.04.

  • I am not getting anywhere tried everything I could to resolve unmet dependencies. Can I just uninstall 13.10 and then install 14.04? – madscott Aug 31 '14 at 12:21
  • I know I could upgrade to 13.10 from 12.04, but in my case upgrading 13.10 fails also. I got busted in upgrade manager while downloading packages. – miro5lav Sep 1 '14 at 16:39

Not the answer you're looking for? Browse other questions tagged or ask your own question.