0

I’m using Ubuntu 14.04 and when i copy files to a USB stick ( format Fat32) the files do get copied onto the USB ok and can be accessed while its plugged into my Ubuntu laptop.

but its when I try to use the USB Stick on other computers, windows or Mac the files ( which are compatible on all OS systems ) cannot be view, used or the USB stick appears to be empty. except when I plug it back into my Ubuntu laptop the files are there and works. i have also tried other USB Sticks and ext hard drives i still have the same problem. Any help would be great, i really don't want to go back to using Windows.

2
  • If you have nothing to lose on the flash drive (AKA it's still on the laptop) try this for a diagnostic step: Format it as NTFS using gparted, put some files on it, and see if windows can see it.
    – Mitch
    Aug 30, 2014 at 3:41
  • Thanks But it didnt work i just tried it with 2 different flash drives. Aug 30, 2014 at 4:27

1 Answer 1

1

I had a same problem, or clearly Ubuntu still has this problem that copy dialog is finished and is closeed until without completing copy process. If you see blink LED on your USB flash, it is blinking already, it means still copy not finished but unfortunately copy dialog closed before. I think it's a big bug on Ubuntu.

My solution is : wait for blink LED until it turn off that means copy is finished. Alternatively run sync in terminal and wait until it's completed. After that, use "Eject" or "Unmount" and remove the USB Flash.

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.