23

I have Ubuntu 14.04 with Cinnamon. When I log in, Skype autolaunches and I want to stop that.

I looked in Startup Applications but cannot find it.

12 Answers 12

15

Had the same issue on Ubuntu 17.10 and fixed it with the following command:

rm ~/.config/autostart/skypeforlinux.desktop

And as Tim mentions here, disable autostart in the Skype settings because Skype will keep on adding the skypeforlinux.desktop file to the ~/.config/autostart directory.

[*] I know the question is about Ubuntu 14.04 but I came across this page while searching for a solution for Ubuntu 17

10

If you installed Skype via Snap the paths (as of Ubuntu 20.04) are:

~/snap/skype/162/.config/autostart/skypeforlinux.desktop
~/snap/skype/common/.config/autostart/skypeforlinux.desktop

I found @alokym's solution quite good. Don't forget his second step, though.

1
  • Use this instead: sudo find ./ -regextype posix-egrep -regex "./snap/skype/[0-9]+/.config/autostart/skypeforlinux.desktop" -delete – logbasex Mar 17 at 18:55
4

Try running the following command:

rm .config/autostart/skype.desktop

It should remove it from starting automatically. You will also need to change the settings in skype, otherwise each time you open it, it is set to open automatically.

1
  • cannot access .config/autostart/skype.desktop: No such file or directory – Ger Hooton Aug 29 '14 at 22:15
3

As Stunts mentioned skypeforlinux recreates autostarting shortcut ~/.config/autostart/skypeforlinux.desktop. So, removing this file doesn't have any sense. But we can disable autostarting with two steps:

  1. open ~/.config/autostart/skypeforlinux.desktop with your favorite text editor and set X-GNOME-Autostart-enabled to false (as KB5 says). Here is my skypeforlinux.desktop:
[Desktop Entry]
Name=Skype for Linux
Comment=Skype Internet Telephony
Exec=/usr/bin/skypeforlinux
Icon=skypeforlinux
Terminal=false
Type=Application
StartupNotify=false
X-GNOME-Autostart-enabled=false
  1. deny overwriting the skypeforlinux.desktop to prevent changing it by skypeforlinux:
chmod a-w ~/.config/autostart/skypeforlinux.desktop
2

You can disable the autostart for Skype by setting changing following value to false in~/.config/autostart/skypeforlinux.desktop file

X-GNOME-Autostart-enabled=false
2

On Ubuntu 20.04 with Skype version 8.73, there is option in the settings to disable autostart. Just go Settings -> General -> "Automatically start Skype".

enter image description here

1
  • Thanks! For me on "Ubuntu 20.04.2 LTS" It's actually Settings > Applications > Search for Skype, "Run in background". But mileage may vary. – Charles Thayer Jul 24 at 20:40
1

Since skypeforlinux will now atomatically recreate the file ~/.config/autostart/skypeforlinux.desktop every time it is started, we now need another way to prevent that. Here is what worked on my case:

rm ~/.config/autostart/skypeforlinux.desktop
mkdir ~/.config/autostart/skypeforlinux.desktop

What will this do? The first command will remove the auto-created .desktop file that makes skypeforlinux autostart on session startup. The second command will create a directory what skypeforlinux normally creates its autostart file. This will prevent skypeforlinux from being able to create the autostart file.

Yes, it is kind of dirty and you are left with an empty directory in ~/.config/autostart, but it does get the job done.

1

I had the same problem and this solved it for me: First run the following command:

rm ~/.config/autostart/skypeforlinux.desktop

Then open Skype and go to Tools, Settings. Go to General and disable "Automatically start Skype". You can also disable "Launch Skype in the backgound" if you want to.

0

This will not help (at least not in my Ubuntu 16.04 LTS) because skype automatically activates itself in the Startup Applications every time it is used. You can stop starting skype by adding a command that will kill skype on startup after skype has started itself:

In the Unity Dash, type: startup and click (under Applications) on "Startup Applications" (this will open "Startup Application Preferences".

Click on "Add" and type under Name: z-kill skype (the "z" at the beginning will make sure that it is further down in the list of applications than skype, and thus starts /after/ skype has started)

and type under Command: killall -9 skypeforlinux (this will kill "skypeforlinux" -- if your skype program has a different name in a different linux version, you have to type in that name)

Good luck! And enjoy your linux without skype imposing on startup ;-)

0

I found an easy way. Just go to Settings in Skype and switch off autostart and something like Κeep Skype ρunning. Skype deleted the ~/.config/autostart file.

0
sudo snap remove skype

once and forever

-2

create a skypestop.sh file and make it executable. put this in:

sudo chmod 444 /usr/share/skypeforlinux/skypeforlinux

to start skype create a start file like skypestart.sh:

sudo chmod 755 /usr/share/skypeforlinux/skypeforlinux

skypeforlinux

when u finish using it run skypestop.sh and that is it

if your skype software is upgrades run skypestop.sh again as the upgrade overwrites the attributes.

2
  • 1
    Bash scripts must start with #!/bin/bash or they won't work. This is also a really messy solution. The stop script makes the software read-only and the start script allows read and execute in addition to write for the owner. I suggest not to use this answer. – Nmath Aug 11 '20 at 17:30
  • please edit your answer and put the neccessary commands in a code section so that it can be more clear.. – kannzzmm2 Aug 16 '20 at 6:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.