0

I'm not sure what precise subject\title should I put for this question because it must be descriptive and short in the same time while the subject is full of details.

Today in the morning I installed the following updates (Latest entries in /var/log/apt/history.log)

Start-Date: 2014-08-29  07:52:16
Commandline: aptdaemon role='role-commit-packages' sender=':1.102'
Install: linux-headers-3.13.0-35:amd64 (3.13.0-35.62), linux-headers-3.13.0-35-generic:amd64 (3.13.0-35.62)
Upgrade: linux-headers-generic:amd64 (3.13.0.34.40, 3.13.0.35.42), multiarch-support:amd64 (2.19-0ubuntu6.1, 2.19-0ubuntu6.3), libc-dev-bin:amd64 (2.19-0ubuntu6.1, 2.19-0ubuntu6.3), libc-bin:amd64 (2.19-0ubuntu6.1, 2.19-0ubuntu6.3), libc6:amd64 (2.19-0ubuntu6.1, 2.19-0ubuntu6.3), libc6:i386 (2.19-0ubuntu6.1, 2.19-0ubuntu6.3), usb-creator-common:amd64 (0.2.56.1, 0.2.56.2), libc6-i386:amd64 (2.19-0ubuntu6.1, 2.19-0ubuntu6.3), usb-creator-gtk:amd64 (0.2.56.1, 0.2.56.2), libc6-dbg:amd64 (2.19-0ubuntu6.1, 2.19-0ubuntu6.3), linux-libc-dev:amd64 (3.13.0-34.60, 3.13.0-35.62), libc6-dev:amd64 (2.19-0ubuntu6.1, 2.19-0ubuntu6.3)
End-Date: 2014-08-29  07:54:34

After that I didn't restart my laptop right away. But I suspended it (I think twice), then I shut it down for sometime.

When I started it again, Ubuntu didn't start. I saw plymouth splash stream flashing dots as usual, but it froze after lighting 2 dots. So I restarted the machine.

Still, Ubuntu didn't start but this time I believe I didn't reach plymouth screen, so I restarted once again. I'm not sure how many restarts I have, but it was 3 at most.

Then Ubuntu started !

  • How can the system manage to fix it self ?
  • Or did it discard the updates may be ?
  • Is it ok to suspend Ubuntu after installing updates ? Or should I restart the machine ?
  • Normally, you don't need to restart after updates. It didn't discard them - could it have been a partial HDD failure which the bios managed to overcome? Or maybe it refreshed a cache somewhere? – Tim Aug 29 '14 at 20:42
0

Ah. You have encountered Ubuntu's alpha stage self-repairing AI. (just kidding there)

Things like this happen all the time. Old objects are in cache, data is in the wrong place, and all sorts of problems occur. The system noticed something wrong and tried to reconfigure stuff back to the defaults. It may have also cleared system caches.

  • Is there a way to track what happened ? – Muhammad Gelbana Aug 30 '14 at 6:22
  • @MuhammadGelbana You might have luck with logs. I do not know what logs would be relevant though. Maybe dmesg? – Kaz Wolfe Aug 30 '14 at 6:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.