1

I'm running Mint 17, and I changed my /etc/apache2/sites-available/000-default.conf file to the following:

<VirtualHost *:80>
    # The ServerName directive sets the request scheme, hostname and port that
    # the server uses to identify itself. This is used when creating
    # redirection URLs. In the context of virtual hosts, the ServerName
    # specifies what hostname must appear in the request's Host: header to
    # match this virtual host. For the default virtual host (this file) this
    # value is not decisive as it is used as a last resort host regardless.
    # However, you must set it for any further virtual host explicitly.
    #ServerName www.example.com

    ServerAdmin webmaster@localhost
    DocumentRoot /home/vg/www

    # Available loglevels: trace8, ..., trace1, debug, info, notice, warn,
    # error, crit, alert, emerg.
    # It is also possible to configure the loglevel for particular
    # modules, e.g.
    #LogLevel info ssl:warn

    ErrorLog ${APACHE_LOG_DIR}/error.log
    CustomLog ${APACHE_LOG_DIR}/access.log combined

    # For most configuration files from conf-available/, which are
    # enabled or disabled at a global level, it is possible to
    # include a line for only one particular virtual host. For example the
    # following line enables the CGI configuration for this host only
    # after it has been globally disabled with "a2disconf".
    #Include conf-available/serve-cgi-bin.conf
</VirtualHost>

# vim: syntax=apache ts=4 sw=4 sts=4 sr noet

The output of $ ls -al at my home directory level:

drwxr-xr-x  2 vg   vg   4096 Aug 29 12:44 www

And inside the www directory:

drwxr-xr-x  2 vg vg 4096 Aug 29 12:44 .
drwxr-xr-x 21 vg vg 4096 Aug 29 12:43 ..
-rwxrwxr-x  1 vg vg   22 Aug 29 12:44 info.php

When I point Firefox to localhost/info.php, I get 403, permission denied.

info.php merely contains:

<?php
    phpinfo();
?>

Any ideas?

1
  • If you're going to down vote, can you at least explain why? – Major Productions Aug 29 '14 at 17:24
8

In ubuntu apache, the default configuration is not to allow random virtual site roots by default

Edit /etc/apache2/apache2.conf, and the following lines (preferably, after the default directory blocks so that you can keep track of the locations you have enabled for site root)

<Directory /home/vg/www>
    Options Indexes FollowSymLinks
    AllowOverride None
    Require all granted
</Directory>

Reload apache and the error should disappear and you should see your site again.

Not the answer you're looking for? Browse other questions tagged or ask your own question.